Announcement

Collapse
No announcement yet.

vBulletin 4.2.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #76
    Thanks Paul. Image verification with reCAPTCHA still doesn't work and gives me the following error: "Image verification could not be verified due to server issues"

    Comment


    • #77
      I now have version 4.2.0 . How to upgrade to version 4.2.5 Beta 2?
      One leap? Or through an intermediate version?
      Can I buy on your site professional installation services?

      Comment


      • #78
        Originally posted by dmx07 View Post
        Thanks Paul. Image verification with reCAPTCHA still doesn't work and gives me the following error: "Image verification could not be verified due to server issues"
        There are no reCaptcha errors I'm aware of, and no one else has reported anything (nor have you ? I dont see any Jiras logged).


        Originally posted by IgorGabrielan63 View Post
        I now have version 4.2.0 . How to upgrade to version 4.2.5 Beta 2?
        One leap? Or through an intermediate version?
        Can I buy on your site professional installation services?
        Just upload the 4.2.5 files and run the upgrader, it runs all the necessary intermediate steps.

        Yes, you can also buy an upgrade package if you want.
        Baby, I was born this way

        Comment


        • #79
          Hi Paul,

          Thanks for your reply. Just submitted to Jira. Maybe reCAPTCHA is not compatible with PHP7?

          Comment


          • #80
            Multiple errors after upgrade to 4.2.5 Beta 2. Not working properly with PHP7.

            15-Feb-2017 20:10:11 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node has a deprecated constructor in /home//public_html/forumrunner/support/stringparser.class.php on line 849 [15-Feb-2017 20:10:11 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node_Text has a deprecated constructor in /home/public_html/forumrunner/support/stringparser.class.php on line 1464 [15-Feb-2017 20:20:06 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser has a deprecated constructor in /home//public_html/forumrunner/support/stringparser.class.php on line 77 [15-Feb-2017 20:20:06 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node has a deprecated constructor in /home//public_html/forumrunner/support/stringparser.class.php on line 849 [15-Feb-2017 20:20:06 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node_Text has a deprecated constructor in /home/public_html/forumrunner/support/stringparser.class.php on line 1464 [15-Feb-2017 20:20:35 UTC] PHP Warning: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LEFT JOIN post AS post ON(post.postid = thread.firstpostid) WHERE thread' at line 10 in /home/public_html/includes/class_core.php on line 1389 [15-Feb-2017 20:21:28 UTC] PHP Warning: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LEFT JOIN post AS post ON(post.postid = thread.firstpostid) WHERE thread' at line 10 in /home/public_html/includes/class_core.php on line 1389 [15-Feb-2017 20:30:07 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser has a deprecated constructor in /home/public_html/forumrunner/support/stringparser.class.php on line 77 [15-Feb-2017 20:30:07 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node has a deprecated constructor in /home//public_html/forumrunner/support/stringparser.class.php on line 849 [15-Feb-2017 20:30:07 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; StringParser_Node_Text has a deprecated constructor in /home//public_html/forumrunner/support/stringparser.class.php on line 1464
            Last edited by Joe D.; Thu 16th Feb '17, 6:04am. Reason: nevermind

            Comment


            • #81
              Two of my b1 one sites that I updated to b2 started giving db errors when entering the usercp after the update and I've had to roll them both back.

              Code:
              Database error in vBulletin 4.2.5 Beta 2:
              
              Invalid SQL:
              
                      SELECT post.pagetext AS preview,
                          thread.threadid, thread.title AS threadtitle, thread.forumid, thread.pollid,
                          thread.open, thread.replycount, thread.postusername, thread.postuserid,
                          thread.prefixid, thread.taglist, thread.dateline, thread.views, thread.iconid AS threadiconid,
                          thread.notes, thread.visible, threadread.readtime AS threadread,
                          thread.lastpost, thread.lastposter, thread.lastposterid, thread.lastpostid
              
                      FROM vb_thread AS thread
                      LEFT JOIN vb_threadread AS threadread ON (threadread.threadid = thread.threadid AND threadread.userid = 1
                      LEFT JOIN vb_post AS post ON(post.postid = thread.firstpostid)
              
              
                      WHERE thread.threadid IN(296167)
              
                      ORDER BY lastpost DESC;
              
              MySQL Error   : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LEFT JOIN vb_post AS post ON(post.postid = thread.firstpostid)
              
              
                      WHERE thr' at line 9
              Error Number  : 1064
              Request Date  : Thursday, February 16th 2017 @ 01:47:10 AM
              Error Date    : Thursday, February 16th 2017 @ 01:47:10 AM
              Script        : http://www.domain.com/usercp.php
              Referrer      : https://www.domain.com/
              IP Address    : 
              Username      : 
              Classname     : vB_Database_MySQLi
              MySQL Version : 5.7.17-log
              Server        :
              User Agent    :
              Last edited by man1c; Thu 16th Feb '17, 9:54am.

              Comment


              • #82
                I've also just been on dragonbyte tech who I read had also updated to b2 and they are giving the same db error on the usercp.

                Code:
                PHP Warning: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LEFT JOIN vb_post AS post ON(post.postid = thread.firstpostid) WHERE thr' at line 10 in ..../includes/class_core.php on line 1389  
                Database error
                The DragonByte Tech | vBulletin Mods & Addons database has encountered a problem.

                Please try the following:
                • Load the page again by clicking the Refresh button in your web browser.
                • Open the www.dragonbyte-tech.com home page, then try to open another page.
                • Click the Back button to try another link.
                The www.dragonbyte-tech.com forum technical staff have been notified of the error, though you may contact them if the problem persists.
                We apologise for any inconvenience.

                Comment


                • #83
                  Please note, as the first post states (and as you should know anyway).

                  Originally posted by Paul M View Post
                  I cannot keep track of issues logged all over the place in threads,
                  Baby, I was born this way

                  Comment


                  • Mikethemix
                    Mikethemix commented
                    Editing a comment
                    The snag is that the Jira tracker link posted here is ONLY for v5, not v4.2.5

                  • Joe D.
                    Joe D. commented
                    Editing a comment
                    As of the time this thread was current. it worked. At this point there is no longer any point to logging bugs in 4.2.5. Security exploits can be reported to [email protected] but nothing else will be recorded or fixed.

                • #84
                  Apologies Paul, submitted to Jira.

                  On some servers vbulletin 4 can develop incredible speed but not with 4.2.5 Beta 2 due to bugs. Not working well with PHP7. Some pages refuse to load, lots of database errors.

                  Also some threads start to behave erraticaly and display in hybrid mode then linear mode.

                  Comment


                  • #85
                    Originally posted by dmx07 View Post

                    On some servers vbulletin 4 can develop incredible speed but not with 4.2.5 Beta 2 due to bugs. Not working well with PHP7..
                    Sorry but this is just exagerated, given how different PHP 7 is, it works very well.

                    First of all, Betas have bugs, thats why they are Betas, these will not have any noticable effect on "speed".

                    Recaptcha looks like the remote system no longer exists, so would fail in any vB4 version.
                    The database error (not errors) are from subscriptions in the usercp. They will affect that page only.
                    The deprecated messages are just warnings, from some old 3rd party stuff forumrunner uses (most people never use FR).

                    Baby, I was born this way

                    Comment


                    • #86
                      Thank you Paul and apologies for my ignorance I didn't want to annoy you.

                      May I ask why do threads start to automatically display in hybrid mode in 4.2.5 Beta 2?

                      Comment


                      • #87
                        Hi Paul,

                        already upgradet vb 4.2.5 beta 2 and everything seems to be fine.
                        One bug maybe is when i wanted to edit the signature. /profile.php?do=editsignature
                        It gives me an error: Invalid File
                        Is that known?
                        ​​​​​​​Thank you!

                        Comment


                        • #88
                          Yes, its because the sig pic field is [still] pre-populated with "http://www.", its supposed to be blank now, but I missed this in some templates.

                          Blank it out manually and the error will go away. Its fixed for Beta 3.
                          Baby, I was born this way

                          Comment


                          • #89
                            Update:

                            There are a huge number of changes in 4.2.5 Beta 2, not just for PHP 7, but also IP storage and many other minor things.

                            Becasue of this, a number of bugs are expected to be found (and a few already have).
                            A number of issues related to just PHP 7.1.1 are also showing up now (and several cases where the code works in PHP 7.1, but fails in PHP 5.6).

                            Please report any issues as soon as you can in Jira (if you dont, I am likely to miss them).
                            I aim to squash as many as possible, and then push out Beta 3 (as just a series of bug fixes) in a much shorter timeframe than Beta 2.
                            Baby, I was born this way

                            Comment


                            • #90
                              Originally posted by Paul M View Post
                              Yes, its because the sig pic field is [still] pre-populated with "http://www.", its supposed to be blank now, but I missed this in some templates.

                              Blank it out manually and the error will go away. Its fixed for Beta 3.
                              thanks Paul. Now it works ok. Great help

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X