Announcement

Collapse
No announcement yet.

vBulletin 4.2.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • too_cool_3
    replied
    Hi Paul, yes I understand I will loose any products built for vB4. I will have to update the producst to vB5 version (if available) and rebuild any custom styles.

    Leave a comment:


  • Paul M
    replied
    If you really want to upgrade then you can just go direct from 421 > 530.

    I presume you do understand you will lose all custom styles and products ?

    As far as the server goes, its always best (IMO) to upgrade VB first, then the PHP/MySQL software (you need to do one, then the other straight after)

    Leave a comment:


  • too_cool_3
    replied
    Paul M I'm currently running vB 4.2.1 and looking to move to vB5. Is it best for me to upgrade from 4.2.1 > 4.2.4 > 5.3.0 or jump directly 4.2.1 > 5.3.0?

    My host, URLJet runs PHP 5.4.45 and MySQL Version 5.5.45-cll-lve on the server.
    Is this my best order of operation?
    1. update vB 4 to vB 5
    2. update PHP to 7.1
    3. update MySQL to 5.7.0

    Thanks for your help.

    Leave a comment:


  • Paul M
    replied
    Generally its better to update vb first, and then php.
    If you did it the other way round, the upgrader may fail.

    Of course, you should do one, then the other [straight after].

    Leave a comment:


  • MrFurious
    replied
    So question: What's the proper order of operations here since we have to update two different bits of software. Should I do the vb update first and then update my PHP, or vise-versa?

    Leave a comment:


  • Paul M
    replied
    I dont know how cPanel works, but I would imagine you would need to restart something for any php change to take effect.

    Leave a comment:


  • wesman2232
    replied
    I think it's because it's throwing errors before the version check due to the incompatible PHP version. I'm currently in a chat session with Hostgator right now about our PHP version.
    The PHP version we have been using was 5.4.45. Knowing we needed PHP 5.5+ I went to the live chat once and was told to use the PHP Selector in our cPanel. Well changing it there to PHP 5.5 and trying to upgrade didnt work, started throwing this error:
    Code:
    Parse error: syntax error, unexpected '=', expecting ')' in /home4/d10g2t0r/public_html/forum/includes/functions_misc.php on line 759
    That line being
    Code:
    if (empty($postvars_encoded = json_encode($_POST)))
    Obviously that's because our PHP version isnt the one needed for vB 4.2.4 since PHP Manual says that should work fine with PHP 5.5

    Trying again with Live Chat Support to see if it'll actually upgrade this time from their end. I know it's the hosting company's fault and not vBulletin's since our upgrade script is a fresh download from the Member's Area.

    Leave a comment:


  • Paul M
    replied
    Well thats the odd thing.
    The installer/upgrader has a version check in it (always has), so I'm not sure why they are not seeing any error message.

    Leave a comment:


  • man1c
    replied
    Paul, I notice a few posts over the last few days with people upgrading with incompatible php versions - for the next version of 4.2.5 could you not have a required php version check on upgrade.php that can stop them until they upgrade and save any future support threads?

    Edit: or if not a check, a note on the upgrade page listing the minimum requirements.

    Leave a comment:


  • Paul M
    replied
    That list looks about right to me.

    Leave a comment:


  • wesman2232
    replied
    Originally posted by blue7 View Post

    Where i can find full change logs for vB 4.2.4?

    Edit: Found it: http://tracker.vbulletin.com/secure/...&version=11583
    Is there an official changelog for vB 4.2.4? This link seems to be empty.

    EDIT: Sorry, for some reason when I go to it from his link it's blank, but when I went and searched for it myself through the tracker, it has it all there even though it's the same link. Weird. Anyway this is the correct link, it just might need loaded from the tracker dashboard and all.
    Last edited by wesman2232; Sun 5th Mar '17, 11:58am.

    Leave a comment:


  • Paul M
    replied
    Sorry, thats not going to happen.

    Leave a comment:


  • Cobra SA
    replied
    fix facebook connect please pretty please with sugar on top ;______;

    Leave a comment:


  • djbaxter
    replied
    Sorry. I misread your earlier statement to mean that vBulletin 4.2.4 was going to be the final version of vB4.

    Leave a comment:


  • Paul M
    replied
    Well as a wild guess, because its about vB 4.2.5 ... maybe ...

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X