Beta 3 was released yesterday, which includes the latest security fixes.

Note that 4.2.4 requires php 5.5.0 as a minimum, however, it is not supported on php 7.