Announcement

Collapse
No announcement yet.

My Server was down, when it came back up some tables were missing from the database structure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phaedrus
    replied
    I wish you had posted that a bit earlier... I'd have loved to give it a try.

    Leave a comment:


  • Wayne Luke
    replied
    The search tables contain volatile data that can be rebuilt. Copy their table definitions out of the /install/mysql-schema.php file and recreate them. Then rebuild the search index in the AdminCP under Maintenance -> General Update Tools.

    The tag and tagcontent tables can't be rebuilt but if tags aren't important to you, then you can start those tables from scratch as well using the same file as above.

    Leave a comment:


  • kh99
    replied
    If that's the complete list of tables that failed, it might be worth trying to restore only those tables from the old backup, since those tables aren't the ones that store posts or users.

    Leave a comment:


  • Phaedrus
    replied
    Well, I did find an uncorrupted backup... from 2014... At least I didn't lose all 9 years of posts. Just one and one half... D'oh!

    Leave a comment:


  • Phaedrus
    replied
    Dang. That's sad. I upgraded mysql on the 15th of October and every backup since has been corrupted. Looks like I'm going to lose quite a few posts. This makes me a bit sad.

    Leave a comment:


  • Mark.B
    replied
    You can't just put back blank database tables. The data will be missing and the chances are the forum will not function at all.

    There's no way to fix this from our end, you will need to ask your host to restore from backup.

    Leave a comment:


  • Phaedrus
    replied
    If I run an install on top of what is there would it rebuild the tables? Would I lose all the data?

    Leave a comment:


  • My Server was down, when it came back up some tables were missing from the database structure

    How do I restore these?
    [****pla_********indata.contenttype] Error: Table '****pla_********indata.contenttype' doesn't exist
    [****pla_********indata.searchcore] Error: Table '****pla_********indata.searchcore' doesn't exist
    [****pla_********indata.searchcore] status: Operation failed
    [****pla_********indata.searchcore_text] status: OK
    [****pla_********indata.searchgroup] Error: Table '****pla_********indata.searchgroup' doesn't exist
    [****pla_********indata.searchgroup] status: Operation failed
    [****pla_********indata.searchgroup_text] status: OK
    [****pla_********indata.searchlog] Error: Table '****pla_********indata.searchlog' doesn't exist
    [****pla_********indata.tag] Error: Table '****pla_********indata.tag' doesn't exist
    [****pla_********indata.tag] status: Operation failed
    [****pla_********indata.tagcontent] Error: Table '****pla_********indata.tagcontent' doesn't exist
    Last edited by Phaedrus; Thu 5 Nov '15, 7:12pm. Reason: trying to make it readable
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X