Announcement

Collapse
No announcement yet.

Please help: When an article is PUBLISHED a blank page results.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help: When an article is PUBLISHED a blank page results.

    In vBull 4.2.3 I can create a new article, edit and save it. I can see the unpublished article on the originating page. I can click the pencil icon and edit it some more. However, when I click PUBLISH and save, I get a blank page. I can see the published article on the originating page, but if I click on it or on read "more" I get a blank page. I cannot edit it, I cannot even see it. I can navigate directly to the published page URL and that will show a blank page.
    I have not found any way to restore the page; I can delete it.from the list on the originating page.

    Here are possible solutions that I tried but none of these have worked:
    1. Repairing and optimizing the tables
    2. Upgrading to vBull 4.2.3
    3. Changing the style to a new or a default style
    4. Updating to PHP 5.5.30
    5. This happens with or without attachments
    6. Disabling all plug-ins had no effect.
    7. There are no suspect file versions
    8. This happens in Chrome, Firefox and Internet Explorer on Windows 7 and 8.
    Are there logfiles or diagnostic information somewhere in my site that can give me clues? What else do you think I should I try? Thank you for any suggestions you may have.

  • #2
    There is almost certainly an actual php error message behind this.

    Please check your server logs and pull out whatever error is showing for the times you've submitted an article.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Thank you for pointing me to these logs. Here is the transcript as the error occurs. I do not know what to do with this information. Can you suggest a next step?

      [06-Oct-2015 14:53:59 America/New_York] PHP Warning: require_once(includes/functions_ghsom.php): failed to open stream: No such file or directory in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      [06-Oct-2015 14:53:59 America/New_York] PHP Fatal error: require_once(): Failed opening required 'includes/functions_ghsom.php' (include_path='.;C:\php\pear') in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      [06-Oct-2015 14:54:08 America/New_York] PHP Warning: require_once(includes/functions_ghsom.php): failed to open stream: No such file or directory in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      [06-Oct-2015 14:54:08 America/New_York] PHP Fatal error: require_once(): Failed opening required 'includes/functions_ghsom.php' (include_path='.;C:\php\pear') in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      [06-Oct-2015 14:54:23 America/New_York] PHP Warning: require_once(includes/functions_ghsom.php): failed to open stream: No such file or directory in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      [06-Oct-2015 14:54:23 America/New_York] PHP Fatal error: require_once(): Failed opening required 'includes/functions_ghsom.php' (include_path='.;C:\php\pear') in C:\inetpub\vb3\includes\class_dm_threadpost.php(1848) : eval()'d code on line 16

      Comment


      • #4
        These are from a modification.

        Please try the following:

        1. To disable the plugin/hook system completely, edit includes/config.php and add the following code:
        Just below
        Code:
        <?php
        enter
        Code:
        define('DISABLE_HOOKS', true);
        2. Now go to AdminCP > Style Manager
        and create a new style with no parent.
        Now browse your forum using this new style.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.6 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Thank you. The problem was solved by copying a backup version of ghsom.php to the includes directory. Now working as it should. As some note ghsom.php is not a vBulletin file, it belongs to an antispam plugin. There was no need to disable the plugin completely. In case others have this same problem, editing the config.php with "define('DISABLE_HOOKS', true); did not solve the problem.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X