Announcement

Collapse
No announcement yet.

Errors after host upgraded PHP to mysqli (and yes, I changed config.php)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors after host upgraded PHP to mysqli (and yes, I changed config.php)

    Site is running vB 4.3.
    Host is now running php 5.6.7-1, and sql 5.7.70-log, with mysqli

    edited config.php from mysql to mysqli, and site is somewhat up.

    However, getting error messages, not sure where to look, as searching here has only resulted in results pointing to people forgetting to change the config.php file.

    I haven't messed with mysql in a couple years, so I'm feeling very rusty. Thanks for understanding.

    Looks like I need to change another mysql entry somewhere - Here are the error codes;

    PHP Warning: mysql_query(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in ..../newreply.php(301) : eval()'d code on line 3

    PHP Warning: mysql_query(): A link to the server could not be established in ..../newreply.php(301) : eval()'d code on line 3

    PHP Warning: mysql_fetch_array() expects parameter 1 to be resource, boolean given in ..../newreply.php(301) : eval()'d code on line 4


  • #2
    Those errors look like they are from a plugin.
    Baby, I was born this way

    Comment


    • #3
      Thanks, Paul - I was like *duh* after I posted - I disabled hooks, and it's working without errors, going through the plugins now.

      Sigh, that's what I get for not being more involved with things the last couple years. I'm almost 50, so I'll call it a senior moment ; )

      Again, thank you for the prompt response.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X