Announcement

Collapse
No announcement yet.

CPU 100%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CPU 100%

    Over the last 2 weeks I have been suffering huge spikes in entry processes and CPU usage is constantly hitting 100%

    I have had a search on here and am not able to find anything overly helpful (possibly looking in wrong place) I also have a huge number of google bots upwards of 20 at a time. I have managed to cull the weibu, and many others this has helped a little bit however still the problem exists.

    vB 4.2.2 Patch Level 1

    I have only just taken over admin on the site and have not been able to create a test version yet to upgrade or apply patches.

    Any help would be appreciated.

  • #2
    How many third party modifications is the site using?

    Comment


    • #3
      You should apply the latest security patches.

      Comment


      • #4
        In the interim I have now managed to update to 4.2.2 Lvl 4. (as I am unable to find 4.2.3 in the download section) So this is the latest version that I have available at this point in time.

        Only plugins running are:

        Ban Spider by UserAgent 3.1.3
        VSa Paypal Donate 5.0.3

        Comment


        • #5
          Is it your own server, not shared and if so is the forum the only site on the server?

          Comment


          • #6
            To disable the plugin/hook system completely, edit includes/config.php and add the following code:
            Just below
            Code:
            <?php
            enter
            Code:
            define('DISABLE_HOOKS', true);
            4.2.3 is in the members area as normal. Note that 4.2.3 requires a minimum of php 5.4.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.6.3 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Originally posted by donald1234 View Post
              Is it your own server, not shared and if so is the forum the only site on the server?
              It is a shared server. there is also a Wpress site on the server which is barebones and uses nothing in resource. (I know WP inside/out so eliminated that being an issue first).

              Comment


              • #8
                Try disabling your plugins as MarkB has suggested to rule that out as a cause, if not you should take up the issue with your hosting provider.

                Comment


                • #9
                  Have disabled plugins, seems to still be a problem. Hosting company now moving us to VPS

                  Comment


                  • #10
                    Server Load Averages 2.80 2.35 3.66 | 42 Users Online (15 members and 27 guests)

                    Comment


                    • #11
                      Originally posted by nzodie View Post

                      It is a shared server. there is also a Wpress site on the server which is barebones and uses nothing in resource. (I know WP inside/out so eliminated that being an issue first).

                      For a shared server, the loads you're describing are normal. Actually low for some providers. If your server has 4 cores in the CPU or multiple CPUs then you're not even at 100% utilization.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API - Full / Mobile
                      Vote for your favorite feature requests and the bugs you want to see fixed.

                      Comment


                      • #12
                        Thanks for all the help so far everyone,

                        Now hosted on a VPS and everything seems to be stable for now 0.21 0.23 0.31 | 36 Users Online (15 members and 21 guests) although I still have
                        Code:
                         
                         define('DISABLE_HOOKS', true);
                        Is there a way to limit the number of bots indexing the site? I have updated to exclude the unwanted ones like weibu and a few others but as I blocked some, I have noticed MSN, Google and yahoo have increased the number of bots.

                        I also have a lot of TOR connections, should these be limited / blocked?

                        Of the 21 guests only 3 are associated with known members.

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X