Announcement

Collapse
No announcement yet.

Incorrect Podcast Enclosure URL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Incorrect Podcast Enclosure URL

    Hello,

    I'm having trouble with getting the correct enclosure URL for my podcast. http://forum.recordingreview.com/ext...p?forumids=181 You'll notice that the enclosure URL is <enclosure url="http://forum.recordingreview.com/attachment.php" length="84068" type="unknown/unknown"/>.

    My goals is to utilize the second option found here http://www.vbulletin.com/docs/html/m...rsion=30602500

    You may upload your media file to your website, or another website, via ftp and link to it directly. To use this method, specify the complete URL in the Podcast URL that appears on the New Thread screen. You do not need to specify the filesize unless your are prompted to after submitting the thread. If you want your media file to appear in the thread to those that are viewing the thread via your forums, you will need to place the link within your post, such as Download: http://www.example.com/podcast.mp3 The handling of the media file will be handled automatically for those that view the podcast forum via RSS.
    Attached is the screenshot from the manual of the form I'll be using:

    Even though I filled out the form with my mp3 URL, it appears that vBulletin has defaulted to an attachment.

    If there is a template I can edit to code the enclosure to utilize a link to from "Podcast URL" that would be awesome. I have no idea what file to edit or what field to put in them.

    Thanks!

    Brandon
    Payday Advance

  • #2
    Update: I dug through the database via phpmyadmin and found under "podcastitems" that none of the data from that form (in the image in the first post) made it to the database. I'll have to troubleshoot to see what's causing that. I manually changed the data in phpmyadmin and the RSS feed looks good now.
    Payday Advance

    Comment


    • #3
      Once I manually entered the data into the podcastitems table, my RSS feed worked great with an external mp3, and iTunes approved it. Today, I noticed my podcast episode were missing from iTunes. The RSS feed has devolved back the exact same URL as I posted in the original thread, and I can not find my corrected row in the postcastitems table.

      Is there any functionality that would remove the podcastitems entry?

      Brandon
      Payday Advance

      Comment


      • #4
        Edit: nvm, I read the complete entry from the manual you linked to above.
        Last edited by kh99; Thu 30th Jul '15, 1:32pm.

        Comment


        • #5
          Thanks for the tip. I've probably read it 20 times. I tracked down some of the problem in external.php. For whatever reason, images are being placed in the enclosure tag as "unknown" and linked to via attachment.php. That's throwing off everything in iTunes. I commented out attachment-based enclosure lines of code and it seems to be working okay now.
          Payday Advance

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X