Announcement

Collapse
No announcement yet.

Error uploading files error 2038

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error uploading files error 2038

    SOLVED

    I've been through several posts now and have not been able to solve this issue.

    VB 4.2.2

    When uploading to a thread or album, the transfer works but then fails with the Error 2038.

    While this issue has been addressed in many other threads, below is what I've tried so far.

    Options-->Attachment Options--> Set to Ajax, No and Flash: No change
    Added the lines to the .htaccess file --> No change
    Changed the directory --> No change
    Verified permissions on all 'attach' directories, all of which are 777, reset to 777 again.
    Used the diagnostics function --> no problem found
    Verified the size of files, 2meg, file is 79k.
    Tried with IE and FireFox--> Same Error
    CPanel-ModSecurity - Disabled -->Same error

    Server Information
    cPanel Version 11.50.0 (build 27)
    Theme paper_lantern
    Apache Version 2.2.29
    PHP Version 5.3.29
    MySQL Version 5.5.42-cll-lve
    Architecture x86_64
    Operating System linux
    Perl Version 5.10.1
    Kernel Version 2.6.32-531.29.2.lve1.3.11.10.el6.x86_64
    All Services are up and running.
    Last edited by MK1Dubz; Wed 29th Jul '15, 11:30am.

  • #2
    Is your temporary directory on the server full?

    Are you storing attachments in the database or filesystem?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Is your temporary directory on the server full?

      Are you storing attachments in the database or filesystem?
      I checked and there were file in the tmp directory, cleaned them up and still have the same issue, I changed the permissions on the tmp to 777 and still have the same problem. The attachments are stored in the file system in the attach directory. I've copied the files to another area, recreated the attach directory, moved the files back and still have the same issue.

      My disk space is barely used, plenty of it.

      Comment


      • #4
        If you're interested in trying something (which I'm not sure will tell us anything), try disabling javascript in a browser, then post to a thread with an attachment (go advanced, then use the "manage attachment" link at the bottom). The Error 2038 is a generic error from the flash uploader which I think is probably getting a response it doesn't understand, like maybe an error message, so I'm thinking if you try an upload without it maybe you'll see something (or not).

        Comment


        • #5
          Tried that, disabled javascript, when uploading I received this: Internal Server Error

          The server encountered an internal error or misconfiguration and was unable to complete your request.
          Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
          More information about this error may be available in the server error log.
          Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

          Comment


          • #6
            I also asked my host, stablehost.com to take a look as they have helped me before, maybe it is something I am missing. They are very good so they may find something.

            Comment


            • #7
              Still having the same issue. My host didn't see any problems.

              Comment


              • #8
                There isn't enough information to figure out what the issue is. You would have to open a support ticket using the link in the footer of this page.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  I checked another use account and got the same error but one thing I noticed is that many of the attachments for not only my account but others come up with the ?. Which tells me there is an issue with the access to the files in order to display the thumbs.

                  Comment


                  • #10
                    Changed the settings to revert back to the old style upload app and this is the error I am getting with that:


                    Warning: Declaration of vB_Image_Magick::fetch_image_info() should be compatible with that of vB_Image_Abstract::fetch_image_info() in ..../includes/class_image.php on line 1256

                    Warning: Declaration of vB_Image_GD::fetch_image_info() should be compatible with that of vB_Image_Abstract::fetch_image_info() in ..../includes/functions_log_error.php on line 2488

                    Comment


                    • #11
                      SOLVED!

                      Added the following 2 lines to the config.php file

                      define('SKIP_ALL_ERRORS', true);
                      define('SKIP_DS_ERRORS', true);



                      I was able to upload and attach.

                      Comment


                      • #12
                        Hmm.. Those warnings shouldn't occur if you were using PHP 5.3.29. They are PHP 5.5 and higher messages.

                        You should upgrade to 4.2.3.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          Originally posted by Wayne Luke View Post
                          Hmm.. Those warnings shouldn't occur if you were using PHP 5.3.29. They are PHP 5.5 and higher messages.

                          You should upgrade to 4.2.3.
                          Ya know, no disrespect. I am about 2 minutes away from scrapping the site and just use a page on facebook.....

                          I was running 3.X everything was great until the host upgraded the php, then I had a ton of errors, fixed most of them with your help, I was told to upgrade. So I upgraded, then I had to upgrade again and now I may need to upgrade because the FB changed something.... I want to spend my time posting my fabrications and such not constantly upgrading and fixing errors.

                          I have a small, low maintenance, no frills site but the management is something that I may need to reconsider.

                          I struggled with this issue for weeks now and glad it is fixed.

                          Comment


                          • #14
                            I'm having this problem too. I am able to upload images using the Basic Uploader. But the Flash Uploader shows this error under a red exclamation mark:

                            406 [IOErroreventype= "ioError" bubles=false Cancelable= falseeventPhrase= 2 text= Error#2038"]

                            I'm running VB 4.2.4 on Apache

                            EDIT: Problem solved. It was a mod_sec2 rule triggered by Flash players. The error showed up in the Apache error log. Just had to turn off the rule.
                            Last edited by BibleWheel; Sat 8th Apr '17, 5:02pm.

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X