Announcement

Collapse
No announcement yet.

Warning/phperror in admincp>maintenance>general update tools

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Warning/phperror in admincp>maintenance>general update tools

    vB4.2.2 PL4
    Firefox/Opera/SeaMonkey/Safari/IE/Chrome

    Trying to sus out inability to post (white page ./error.html) and while in admincp>maintenance>general update tools I have the following show up in the middle of the page:

    Warning
    : Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261

    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337

  • #2
    http://www.vbulletin.com/forum/forum...81#post4000681
    ...

    Comment


    • #3
      seriously 4PL's later and vB is still distributing 4.2.2 packages with this error????

      Comment


      • #4
        PL don't generally deal with non critical bugs/issues. Run 4.2.3 if you want php 5.4/5 compat fixes.

        Comment


        • #5
          As Zachery says, you should upgrade to 4.2.3.

          It's not an error, it's a php warning.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.3 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            Originally posted by Eq4Bits View Post
            seriously 4PL's later and vB is still distributing 4.2.2 packages with this error????
            Correct.

            PL's are not for dealing with minor issues such as that, they are primarily for security issues, and very rarely, serious bugs.
            Baby, I was born this way

            Comment


            • #7
              ick, I didn't see 4.2.3 as a download option (yes, I saw that part of answer in email notification) I'll go see about downloading that (if it's an option...)

              Comment


              • #8
                ummm nope, not gonna download and install 4.2.3 ... there's a note to the side of it that states Unstable. I've got enough issues right now without compounding them with an unstable version release.

                Comment


                • #9
                  Its not unstable in the traditional sense. I'd still suggest upgrading to it over 4.2.2's latest release esp if you need the php 5.5 fixes.

                  Comment


                  • #10
                    Originally posted by Eq4Bits View Post
                    ummm nope, not gonna download and install 4.2.3 ... there's a note to the side of it that states Unstable. I've got enough issues right now without compounding them with an unstable version release.
                    Its only labelled that way because its not (yet) the full release, its RC1.
                    There will be virtually no difference between RC1 and the final version thats due in the next couple of weeks (one minor template change).

                    Baby, I was born this way

                    Comment


                    • #11
                      Originally posted by Paul M View Post

                      Correct.

                      PL's are not for dealing with minor issues such as that, they are primarily for security issues, and very rarely, serious bugs.
                      sorry but if it keeps the software from working without throwing errors because of a continual code issue that is known and not fixed with *current releases* that we have to use then it's not *minor* as it impedes easy use by customers.

                      I hope it was fixed with the 4.2.3 because until I know for sure I won't upload the two files in question and have to go through all this crap again.

                      Comment


                      • #12
                        Originally posted by Eq4Bits View Post

                        sorry but if it keeps the software from working without throwing errors because of a continual code issue that is known and not fixed with *current releases* that we have to use then it's not *minor* as it impedes easy use by customers.

                        I hope it was fixed with the 4.2.3 because until I know for sure I won't upload the two files in question and have to go through all this crap again.
                        Sorry, it is a minor issue. Its a non critical error that you can disable with a single line change in the config file. Or you can run the version that has the fix. Its your call.

                        Comment


                        • #13
                          Originally posted by Eq4Bits View Post

                          sorry but if it keeps the software from working without throwing errors because of a continual code issue that is known and not fixed with *current releases* that we have to use then it's not *minor* as it impedes easy use by customers.

                          I hope it was fixed with the 4.2.3 because until I know for sure I won't upload the two files in question and have to go through all this crap again.
                          It is a minor issue, whether you agree or not, thats how it is.

                          Its your choice whether you upload 4.2.3 or not, no one is going to force you.
                          Baby, I was born this way

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X