Announcement

Collapse
No announcement yet.

Email Diagnostic Error: 550 Unexpected response from SMTP server during TO address

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Diagnostic Error: 550 Unexpected response from SMTP server during TO address

    I am getting the following error when I go into the Admin CP and run a diagnostic on my email SMTP settings:

    "Warning: 550 Unexpected response from SMTP server during TO address transmission in [path]/includes/class_mail.php on line 713"

    The part that doesn't make sense is the exact same settings are being used on another install of vBulletin that connects to the exact same SMTP server and it works fine from there.

    Settings:

    Host: secure.emailsrvr.com
    Port: 25 (also tried 465 and 587)
    Username: sending email address
    Password: sending email address password.

    Everything has been confirmed correct with the host. Password is right. Sending email address is enabled and valid. Port is correct (and when I try changing that, I generate tons of errors so we confirmed the problem isnt the port). Host name is correct. SSL we tried both enabled and disabled with different ports.

    This error keeps coming up. So of course they told me to contact you guys.

    Please advise.
    Helpful forums on hair loss support and information.

  • #2
    550 error is pretty broad. Basically it means the server that you're sending the email to refused it. Either due to some parameters set in the server or the email address is invalid.

    More information here: http://www.serversmtp.com/en/error-550
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Wayne Luke

      I understand, but that isn't the problem here. Its happening with every email address. This is a problem with vBulletin. Can you give me some things to check which would confirm that vBulletin is acting properly? There is no chance that the recipient email addresses are all randomly refusing. This is a diagnostic error being kicked out by vBulletin in the ACP.
      Helpful forums on hair loss support and information.

      Comment


      • #4
        Originally posted by vBBurger View Post
        Wayne Luke

        I understand, but that isn't the problem here. Its happening with every email address. This is a problem with vBulletin. Can you give me some things to check which would confirm that vBulletin is acting properly? There is no chance that the recipient email addresses are all randomly refusing. This is a diagnostic error being kicked out by vBulletin in the ACP.
        A unique issue on your site is not a problem with vBulletin. Something on your mail server is causing this to be rejected.

        To test this, switch to a different SMTP server. Make sure you're using the required port and the required encryption mode. SSL and TSL matters depending on the server and port used.

        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          Hello.

          I'm back. This problem has reappeared, and I did not update this thread to explain how we fixed it last time.

          Unfortunately after a full hour on the phone with Rackspace support once again (I have a dedicated server with them) they have concluded that its a problem with vBulletin.

          Their reasons for saying so include comments like: "You are authenticating just fine but no email is being sent." and "Your username and password and all your settings are correct"

          Further, we fully verified that I am able to send the email without any problem using identical settings from other platforms. Like Microsoft outlook. And their webmail client.

          All of these tools link into their SMTP host and work perfectly fine.

          Its only vBulletin which is failing.

          I have told them: "When I ask vBulletin to give me some answer for this, they just tell me to ask you instead"..... but they tried their best for over an hour.

          We have also checked server logs and they only show successful connections but no emails being sent.

          If anyone can think a little deeper on this and give me some possible tips, I would appreciate it.

          BlackSurfers response above unfortunately also not an option - it seems hes just suggesting using PHP Mail to send instead of SMTP.

          I should note: everything was working perfectly fine with this setup for months.

          Helpful forums on hair loss support and information.

          Comment


          • #6
            What specific version of vBulletin and PHP are you using?
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              vBulletin: 4.2.0 Patch Level 4.
              PHP: 5.3.3


              PS - I've confirmed two different installs of vBulletin are generating the same error, on two different domain names - both on the same dedicated server with Rackspace. Using Rackspace's "Email and Apps" SMTP system.
              Helpful forums on hair loss support and information.

              Comment


              • #8
                I have now also tried hotmail and gmail using their standard SMTP information.

                Same problem but it changes slighly:

                GMAIL
                -------------------------------------------------
                smtp-relay.gmail.com
                Port 25
                My email address
                My password (correctly entered)
                SMTP Secure Connection: None
                Error: Warning: 550 Unexpected response from SMTP server during FROM address transmission in [path]/includes/class_mail.php on line 713

                HOTMAIL
                -------------------------------------------------
                smtp.live.com
                Port 25
                My email address
                My password (correctly entered)
                SMTP Secure Connection: None
                Error: Warning: 530 Unexpected response from SMTP server during FROM address transmission in [path]/includes/class_mail.php on line 713
                I repeat - despite the 530 error - password was entered correctly!


                MY SERVER SETTINGS
                --------------------------------------------------
                smtp.emailsrvr.com
                Port 25
                My email address
                My password (correctly entered)
                SMPT Secure Connection: None
                Error: Warning: 550 Unexpected response from SMTP server during TO address transmission in [path]/includes/class_mail.php on line 713
                Last edited by vBBurger; Wed 18th Nov '15, 6:25pm.
                Helpful forums on hair loss support and information.

                Comment


                • #9
                  GMail and Hotmail/outlook both expect SSL/TLS turned on.

                  Comment


                  • #10
                    Originally posted by Zachery View Post
                    GMail and Hotmail/outlook both expect SSL/TLS turned on.
                    I tried it with SSL and port 465 just now and its saying:

                    Warning: 534 Authorization to the SMTP server failed in [path]/includes/class_mail.php on line 713

                    -------------------------------------

                    I tried Hotmail with SSL and port 587 and its saying:

                    Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol in [path]/includes/class_mail.php on line 747
                    Warning: fsockopen(): Failed to enable crypto in [path]/includes/class_mail.php on line 747
                    Warning: fsockopen(): unable to connect to ssl://smtp.live.com:587 (Unknown error) in [path]/includes/class_mail.php on line 747
                    Warning: Unable to connect to SMTP server in [path]/includes/class_mail.php on line 713
                    Last edited by vBBurger; Wed 18th Nov '15, 7:14pm.
                    Helpful forums on hair loss support and information.

                    Comment


                    • #11
                      Be very sceptical when a host tells you "it's a problem with vBulletin". If it was, we'd have thousands of customers all reporting the same issue.
                      When hosts say this, it usually means they haven't a clue what the problem is so will blame someone else.

                      Do be aware that Gmail (and possible Hotmail as well) will not allow sending via their SMTP server where the "from" address differs from the actual email address being authenticated. The mail simply won't go out. If you're using Gmail as as smtp then your emails need to be visibly sent "from" the same Gmail account you are authenticating with.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.5.6 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #12
                        your emails need to be visibly sent "from" the same Gmail account you are authenticating with.
                        Hello -

                        I am using the diagnostic tool for testing the email sending system. On the Email Settings page, you only get one field for "email address". I assume its a given that the sender is the same as the user being authenticated. They are one in the same, no?

                        Activation emails are not being sent. Errors are being generated regardless of the SMTP system being used. We've verified that this does not happen in any other system using the same credentials. Whether it be Microsoft Outlook, Webmail, Hotmail.com, or Gmail.com. Its only happening when using vBulletin.

                        This should prove that this is a problem with vBulletin or its interaction with my server. Rackspace does not support 3rd party software, but has spent 3 hours breaking that rule to help me out since I am not getting much help here. I would really appreciate some thinking / effort on this so we can figure it out and resolve it. Is there anything else I should check? Verify? Make sure of?

                        Help.
                        Last edited by vBBurger; Fri 20th Nov '15, 10:55am.
                        Helpful forums on hair loss support and information.

                        Comment


                        • #13
                          *crickets*

                          Maybe it's time we move to another forum software.
                          Helpful forums on hair loss support and information.

                          Comment


                          • #14
                            Are you able to send email via another scripts like PhpMailer ? I can send the files if you need help about phpmailer
                            have a look at : http://stackoverflow.com/questions/1...ugh-php-mailer

                            Former vBulletin Support Staff
                            Need Help?, Or P.M. Me

                            Comment


                            • #15
                              Originally posted by vBBurger View Post

                              I tried it with SSL and port 465 just now and its saying:

                              Warning: 534 Authorization to the SMTP server failed in [path]/includes/class_mail.php on line 713

                              -------------------------------------

                              I tried Hotmail with SSL and port 587 and its saying:

                              Warning: fsockopen(): SSL operation failed with code 1. OpenSSL Error messages: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol in [path]/includes/class_mail.php on line 747
                              Warning: fsockopen(): Failed to enable crypto in [path]/includes/class_mail.php on line 747
                              Warning: fsockopen(): unable to connect to ssl://smtp.live.com:587 (Unknown error) in [path]/includes/class_mail.php on line 747
                              Warning: Unable to connect to SMTP server in [path]/includes/class_mail.php on line 713
                              Do you have OpenSSL and a proper certificate installed on the server?

                              http://stackoverflow.com/questions/1...ix-my-ssl-cert

                              PHP is saying that it can't even open an SSL connection.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API - Full / Mobile
                              Vote for your favorite feature requests and the bugs you want to see fixed.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X