Announcement

Collapse
No announcement yet.

Problems with inline mod dropdown menu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sqυιd
    replied
    The problem isn't with the post thanks hack but I'll quote the post I made at vb.org with the changes required to update vbulletin-core.js so the error doesn't happen.

    You can try the same change I used for the same problem for the Separate Sticky and Normal Threads Product
    Assuming you have compressed javascript make the following changes to clientscript/vbulletin-core.js

    Search for this.collection[A].checkbox.check and you add the bit in red:

    Code:
     
     if([B][COLOR=red]this.collection[A].checkbox&&[COLOR=blue]this.collection[A].checkbox.checked[/COLOR][/B])
    [/COLOR]
    The next two changes are trickier because you need to surround lines of code with an if statement.


    Search for this.checkbox.checked=! and add the two bits in red:

    Code:
    [B][COLOR=red]if(this.checkbox){[/B]switch(A[1]){case"invert":[B][COLOR=blue]this.checkbox.checked=![/COLOR][/B]this.checkbox.checked;break;case"none":this.checkbox.checked=false;break;case"class":this.checkbox.checked=YAHOO.util.Dom.hasClass(this.container,A[2]);break;case"flag":if(typeof A[2]!=undefined&&!isNaN(A[2])){this.checkbox.checked=this.checkbox.value&A[2]}else{this.checkbox.checked=true}break;default:case"all":this.checkbox.checked=true;break}[B][COLOR=red]}[/COLOR][/B]
    [/COLOR]
    Search for this.checkbox.check? and add the two bits in red:

    Code:
    [B][COLOR=red]if(this.checkbox){[/B]var A=([B][COLOR=Blue]this.checkbox.checked?[/COLOR][/B]"addClass":"removeClass");YAHOO.util.Dom[A](this.container,"imod_highlight");console.log("Set Inlinemod State for %s - %s",this.itemid,A)[B][COLOR=red]}[/COLOR][/B]
    [/COLOR]
    You can also vote to have the issue resolved at http://tracker.vbulletin.com/browse/VBIV-6156, you'll need to be logged in to vb.com to see the bug report.

    Leave a comment:


  • Wayne Luke
    replied
    You will need to contact the author of the post thanks hack for an update. We can't support hacks and addons. Until you get an update, you'll have to turn it off.

    Leave a comment:


  • malcolmtay
    replied
    Hi Can anyone help with my last post

    Leave a comment:


  • malcolmtay
    replied
    Originally posted by Wayne Luke View Post
    You would have to disable the plugins one at a time until the problem goes away. The last one you disabled would be the one causing the problem.

    Ok i found the problem its the post thanks hack when i turn that off the inline mod menu works perfectly.But i like the post thanks hack can you i suggest anything i can do for this to work with the post thanks hack turned on

    Can i add anything to my config php file for this to work

    Many thanks
    Last edited by malcolmtay; Wed 6 May '15, 2:33pm.

    Leave a comment:


  • Wayne Luke
    replied
    You would have to disable the plugins one at a time until the problem goes away. The last one you disabled would be the one causing the problem.

    Leave a comment:


  • malcolmtay
    replied
    Originally posted by Wayne Luke View Post
    If you use a new style with no parent, does it work? You would have to visit each page to select and add those posts to your "collection".
    What i have just done is disable the plugins and it now works

    How would i find out which plugin it is

    Many thanks Wayne

    Leave a comment:


  • Wayne Luke
    replied
    If you use a new style with no parent, does it work? You would have to visit each page to select and add those posts to your "collection".

    Leave a comment:


  • malcolmtay
    replied

    Is this something in the setting that i need to tweak
    Last edited by malcolmtay; Wed 6 May '15, 11:40am.

    Leave a comment:


  • malcolmtay
    started a topic Problems with inline mod dropdown menu

    Problems with inline mod dropdown menu

    Can someone help me please? I'm having problems with the inline mod dropdown menu. Specifically, I am trying to select unapproved posts, but nothing happens. Then I tried to select all, and that only selects the first post of the thread. Any ideas?

    I'm trying to fix this problem . I just had my moderators go through a thread that was well over 100 pages deep, had them "unapprove" all posts that were off topic, and now I want to select all those unapproved posts so I can move them all to a new thread, for this off topic discussion. I would love some help from the geniuses here. Thank you.

    Whats happening the drop down menu does not seem to be working and when the moderators unapprove a post it goes straight to the admin panel for moderation.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X