Announcement

Collapse
No announcement yet.

Webmaster Tools Errors related to Mobile Usability

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Webmaster Tools Errors related to Mobile Usability

    Hi

    Google Webmaster Tools is showing a lot of errors related to the following categories with respect to Mobile Usability.
    Show
    10 rows


    1 - 4 of 4


    1 Viewport not configured
    2 Small font size
    3 Touch elements too close
    4 Content not sized to viewport





    Are there any ways to fix these errors with Vbulletin 4?

  • #2
    you need to set your style to the mobile theme for mobile devices.

    Comment


    • #3
      Any ideas how to do that so that it is automatically defaulted to the mobile theme when a user is using their tablet or mobile phone to access our forums???

      Comment


      • #4
        The setting's in the ACP under Settings/Options/Style & Language Settings although I'm forcing my mobile style to mobile devices and I'm still getting those errors in my Google Webmaster account.

        Comment


        • #5
          Originally posted by dan325ci View Post
          Any ideas how to do that so that it is automatically defaulted to the mobile theme when a user is using their tablet or mobile phone to access our forums???
          It should already.

          Originally posted by woodmj View Post
          The setting's in the ACP under Settings/Options/Style & Language Settings although I'm forcing my mobile style to mobile devices and I'm still getting those errors in my Google Webmaster account.
          Just because it is testing, it doesn't mean that it is seeing the mobile style. In fact, unless it is sending a mobile user agent, it will see the main site. You should test the site on your mobile device to see if it is satisfactory.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Try checking the pages that Google says are errors. I got those messages for one of my forums and it turned out to be archive pages only. I turn the archives off on my forums but had apparently forgotten to do that for that one forum.

            The archive pages aren't needed and basically just create duplicate content anyway.
            Psychlinks Web Services Affordable Web Design & Site Management
            Specializing in Small Businesses and vBulletin/Xenforo Forums

            Comment


            • #7
              Originally posted by Wayne Luke View Post

              It should already.



              Just because it is testing, it doesn't mean that it is seeing the mobile style. In fact, unless it is sending a mobile user agent, it will see the main site. You should test the site on your mobile device to see if it is satisfactory.
              Oh yes i just checked my Settings for Styles and Templates for Default Style for Mobile Browsers and it was set to NONE....i since turned it on to Default Mobile Style and it fixed the problem.
              Default Style for Old Mobile Browsers
              Select the default mobile style for old mobile browsers. This style will be used if user is browsing your forum with an older mobile browser. Set to 'None' to use desktop browser style. None Mobile Style Premium
              Default Style for Modern Mobile Browsers
              Select the default mobile style for modern mobile browsers. This style will be used if user is browsing your forum with a modern mobile browser. Set to 'None' to use desktop browser style. None Mobile Style Premium

              Comment


              • #8
                I have the same issue on vB4. How can I make the mobile style show by default for mobile users?


                Comment


                • #9
                  Originally posted by giorgioarmani View Post
                  I have the same issue on vB4. How can I make the mobile style show by default for mobile users?

                  It already will with default settings. If you visit your site on your device and it doesn't what do you have set for the Mobile Style under Settings -> Options -> Style & Language Options?
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    I'm replying to this thread because it is basically the same problem I have, but mine adds another element to the problem. Maybe someone will find it in google and be helped.

                    My problem is that the main part of the forums is working fine on mobile.

                    But Google is telling me that nearly 8,000 of my pages are not correct for mobile. And they are all in the vBulletin software.

                    They all seem to be in the "Archive" area. This is one of the pages that is coming up bad:
                    http://www.hairlosstalk.com/interact...p/t-79274.html Text too small to read


                    Mobile viewport not set


                    Links too close together


                    =======================
                    EDIT: FOUND ANOTHER THREAD ON THE TOPIC AND INSTALLED THIS "PRODUCT" (PLUGIN).

                    ITS NOW REDIRECTING ALL ARCHIVE PAGES TO THE MOBILE-FRIENDLY ORIGINAL THREAD:
                    http://www.vbulletin.org/forum/showt...hreadid=317477
                    Last edited by vBBurger; Fri 13th Nov '15, 11:36am.
                    Helpful forums on hair loss support and information.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X