Announcement

Collapse
No announcement yet.

'New Posts' not working after upgrade to vBulletin 4.2.2 Patch Level 4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 'New Posts' not working after upgrade to vBulletin 4.2.2 Patch Level 4

    Hello all,

    After upgrading from 4.2.2 PL1 to 4.2.2 PL 4 the 'New Posts' links no longer work, i.e. the following:

    mysite.co.uk/search.php?do=getnew&contenttype=vBForum_Post

    Users get the following message:

    Sorry, there are no new posts to view.

    You may search for posts updated during the previous 24 hours, here
    Also worth noting that the word 'here' in the message above links to:

    mysite.co.uk/search.php?do=getdaily

    and that results in the following message:

    Sorry - no matches. Please try some different terms.
    Worth noting that there definitely are new posts

    As per usual I have disabled all plugins and still get exactly the same behaviour.
    This is a signature, with a picture

    sigpic

    UK Motorbike Forum

  • #2
    Under "Message Searching Options" do you have "Queue Search Updates" set to yes? If so, make sure the "Search Queue Updates" schedule task is enabled (although I don't know why upgrading would change any of that). You might also check under "Maintenance > Repair/Optimize Tables to see if the search related tables are OK.

    Comment


    • #3
      Queue Search Updates is set to yes and the scheduled job is active and set to trigger every 10 minutes.

      Repair / Optimize doesn't highlight any issues with the search tables.
      Last edited by MrEyes; Mon 2nd Feb '15, 6:56am.
      This is a signature, with a picture

      sigpic

      UK Motorbike Forum

      Comment


      • #4
        Actually, now I have had a chance to sit down and start to look at this properly it is apparent that the entire search system isn't working properly. No errors, just no results.

        As an example, the site is motorbike related so it is a word that is used very often. If I search that I get:

        Sorry - no matches. Please try some different terms.


        EDIT: Just ran mysqlcheck command line against the DB and this returned no issues. Although I did notice a number of tables I don't recall seeing before. All with names as follows (the number at the end changes):


        taggregate_temp_1410699360

        Is this potential and indication of a failed upgrade? i.e. temp tables being left behind?
        Last edited by MrEyes; Mon 2nd Feb '15, 11:58am.
        This is a signature, with a picture

        sigpic

        UK Motorbike Forum

        Comment


        • #5
          Rightio, following advice from vb.org I have rebuilt the search indexes. This was done via the command line utility as this is a mid to large site and doing this via ACP isn't really viable.

          Unfortunately this made no difference, the problem still remains.

          For reference, here is the output from the reindex:

          [[email protected] temp]# php searchindex.php
          PHP Warning: PHP Startup: apc.shm_size now uses M/G suffixes, please update your ini files in Unknown on line 0
          Please enter the path to your vBulletin directory: /var/www/vhosts/mysite.co.uk/httpdocs/
          Rebuild Search Index
          --------------------
          Note:
          You should not normally need to empty the search index, however if items are showing in search results after they have been permanently deleted then emptying the index and rebuilding the search index will fix this. Search will not work correctly after emptying the index until the index is fully rebuilt.
          Click Here to empty the search index.
          Empty Index [0/1,Default=0]:

          0) All
          3) Forums
          1) Posts
          7) Groups
          5) Group Messages
          11) Visitor Messages
          16) Blog Comments
          15) Blog Entries
          Content type to index [Default=0]: 0
          Turn off DB indexes during rebuild [0/1,Default=0]: 0
          Item id to start at [Default=0]:
          Number of items to process per batch [Default=10000]:

          Building Search Index Forums ...
          IDs 0-140 ... Done (0.22 sec)
          Building Search Index Forums: Done
          Building Search Index Posts ...
          IDs 0-10000 ... Done (26.08 sec)
          IDs 10000-20000 ... Done (26.84 sec)
          IDs 20000-30000 ... Done (25.90 sec)
          <snip>
          My SSH connection timed out at around 140k, so after logon I restarted the index at 140k - the only difference was that I set the rerun to use 1000 batches rather than 10000 as this made progress more obvious. The following is the last few lines of the output

          IDs 2346000-2347000 ... Done (4.88 sec)
          IDs 2347000-2348000 ... Done (2.38 sec)
          IDs 2348000-2348538 ... Done (1.53 sec)
          Building Search Index Posts: Done
          Building Search Index Groups ...
          Building Search Index Groups: Done
          Building Search Index Group Messages ...
          Building Search Index Group Messages: Done
          Building Search Index Visitor Messages ...
          Building Search Index Visitor Messages: Done
          Building Search Index Blog Comments ...
          Building Search Index Blog Comments: Done
          Building Search Index Blog Entries ...
          Building Search Index Blog Entries: Done
          Building Search Index: 0 hours, 59 minutes and 00 seconds
          This is a signature, with a picture

          sigpic

          UK Motorbike Forum

          Comment


          • #6
            Some more movement/info on this:

            Short story, still no worky

            Long story....

            I have stopped APC* by disabling at both PHP (via apc.ini and then restarting httpd) and also vBulletin (config.php). I also confirmed it was stopped by loading the APC admin panel and getting the following:

            No cache info available. APC does not appear to be running.
            I have also issued the following two SQL commands:

            REPAIR TABLE searchcore_text QUICK
            REPAIR TABLE searchgroup_text QUICK
            Per SQL docs these should rebuild the full text indexes.

            As mentioned, neither solution fixed the issue.

            * As an APC related aside I have fixed the PHP warning warning that came up when running searchindex.php via the command line (i.e. PHP Warning: PHP Startup: apc.shm_size now uses M/G suffixes, please update your ini files in Unknown on line 0)
            This is a signature, with a picture

            sigpic

            UK Motorbike Forum

            Comment


            • #7
              Add the following line to your /includes/config.php file, right under the <?php line:
              PHP Code:
              define('SKIP_DS_ERRORS'true); 
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.6 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • MrEyes
                MrEyes commented
                Editing a comment
                Hi Mark, I already have that line in my config.php my changelog shows this as being there for over a year now (it was added to prevent some PHP error displaying after an upgrade)

            • #8
              I am having this exact same issue, just trying Mark.B's suggestion and will report back.

              Comment


              • #9
                Still no further on with this, following advice from vb.org I have done a SQL server level reindex and some other jiggery pockery. The output of this is below. In summary:
                • VB ACP -> Settings -> Options -> Turn Your vBulletin On and Off -> Turn site off
                • Restart MySQL (probably not necessary)
                • repair searchcore_text and searchgroup_text SQL tables
                • Restart MySQL (probably not necessary)
                • truncate searchcore, searchcore_text, searchgroup, searchgroup_text
                • drop and recreate text index on searchcore_text
                • drop and recreate grouptitle index on searchgroup_text
                • rerun searchindex.php (from the do_not_upload package)
                • VB ACP -> Maintenance -> Repair / Optimize Tables -> Select POST table -> Continue
                • VB ACP -> Maintenance -> Repair / Optimize Tables -> Select all thread tables -> Continue
                • VB ACP -> Forums & Moderators -> Forum Blocks Manager -> Reload Block Types
                • VB ACP -> Settings -> Options -> Turn Your vBulletin On and Off -> Turn site on

                As a curious aside, one member was reporting that search was working for them. Turns out what they were doing was going into Advanced Search and under single content types selecting "show results as posts". Which is curious.

                Originally posted by Stuff I Did
                Originally posted by In vBulletin ACP
                VB ACP -> Settings -> Options -> Turn Your vBulletin On and Off -> Turn site off
                Originally posted by SSH to Server
                [[email protected] ~]# /etc/init.d/mysqld restart
                Stopping mysqld: [ OK ]
                Starting mysqld: [ OK ]

                [[email protected] ~]# mysql -h 127.0.0.1 -p -u USERNAME DATABASENAME
                Enter password:

                mysql> REPAIR TABLE searchcore_text QUICK;
                +--------------------------------+--------+----------+----------+
                | Table | Op | Msg_type | Msg_text |
                +--------------------------------+--------+----------+----------+
                | mydb.searchcore_text | repair | status | OK |
                +--------------------------------+--------+----------+----------+
                1 row in set (40.89 sec)

                mysql> REPAIR TABLE searchgroup_text QUICK;
                +---------------------------------+--------+----------+----------+
                | Table | Op | Msg_type | Msg_text |
                +---------------------------------+--------+----------+----------+
                | mydb.searchgroup_text | repair | status | OK |
                +---------------------------------+--------+----------+----------+
                1 row in set (0.10 sec)

                mysql> exit
                Bye
                [[email protected] ~]# /etc/init.d/mysqld restart
                Stopping mysqld: [ OK ]
                Starting mysqld: [ OK ]

                [[email protected] ~]# mysql -h 127.0.0.1 -p -u USERNAME DATABASENAME
                Enter password:

                mysql> truncate searchcore;
                Query OK, 0 rows affected (0.00 sec)

                mysql> truncate searchcore_text;
                Query OK, 0 rows affected (0.11 sec)

                mysql> truncate searchgroup;
                Query OK, 0 rows affected (0.01 sec)

                mysql> truncate searchgroup_text;
                Query OK, 0 rows affected (0.00 sec)

                mysql> drop index text on searchcore_text;
                Query OK, 0 rows affected (0.01 sec)
                Records: 0 Duplicates: 0 Warnings: 0

                mysql> drop index grouptitle on searchgroup_text;
                Query OK, 0 rows affected (0.00 sec)
                Records: 0 Duplicates: 0 Warnings: 0

                mysql> CREATE FULLTEXT INDEX text ON searchcore_text (title, keywordtext);
                Query OK, 0 rows affected (0.00 sec)
                Records: 0 Duplicates: 0 Warnings: 0

                mysql> CREATE FULLTEXT INDEX grouptitle ON searchgroup_text (title);
                Query OK, 0 rows affected (0.00 sec)
                Records: 0 Duplicates: 0 Warnings: 0

                mysql> exit
                Bye

                [[email protected]]# php searchindex.php
                Please enter the path to your vBulletin directory: /var/www/vhosts/mysite.co.uk/httpdocs/
                Rebuild Search Index
                --------------------
                Note:
                You should not normally need to empty the search index, however if items are showing in search results after they have been permanently deleted then emptying the index and rebuilding the search index will fix this. Search will not work correctly after emptying the index until the index is fully rebuilt.
                Click Here to empty the search index.
                Empty Index [0/1,Default=0]: 1

                0) All
                3) Forums
                1) Posts
                7) Groups
                5) Group Messages
                11) Visitor Messages
                16) Blog Comments
                15) Blog Entries
                Content type to index [Default=0]: 0
                Turn off DB indexes during rebuild [0/1,Default=0]: 0
                Item id to start at [Default=0]: 0
                Number of items to process per batch [Default=10000]: 1000

                Building Search Index Forums ...
                IDs 0-140 ... Done (0.11 sec)
                Building Search Index Forums: Done
                Building Search Index Posts ...
                IDs 0-1000 ... Done (2.94 sec)
                IDs 1000-2000 ... Done (2.44 sec)
                IDs 2000-3000 ... Done (2.61 sec)
                IDs 3000-4000 ... Done (2.97 sec)
                <SNIP SNIP SNIP>
                <SNIP SNIP SNIP>
                <SNIP SNIP SNIP>
                <SNIP SNIP SNIP>
                <SNIP SNIP SNIP>
                IDs 2347000-2348000 ... Done (3.50 sec)
                IDs 2348000-2349000 ... Done (3.88 sec)
                IDs 2349000-2350000 ... Done (2.75 sec)
                IDs 2350000-2350784 ... Done (2.58 sec)
                Building Search Index Posts: Done
                Building Search Index Groups ...
                IDs 0-48 ... Done (0.14 sec)
                Building Search Index Groups: Done
                Building Search Index Group Messages ...
                IDs 0-1000 ... Done (3.30 sec)
                IDs 1000-2000 ... Done (3.14 sec)
                IDs 2000-3000 ... Done (3.87 sec)
                IDs 3000-4000 ... Done (3.48 sec)
                IDs 4000-5000 ... Done (2.17 sec)
                IDs 5000-6000 ... Done (3.24 sec)
                IDs 6000-7000 ... Done (3.05 sec)
                IDs 7000-8000 ... Done (1.84 sec)
                IDs 8000-9000 ... Done (3.54 sec)
                IDs 9000-9584 ... Done (0.33 sec)
                Building Search Index Group Messages: Done
                Building Search Index Visitor Messages ...
                IDs 0-1000 ... Done (3.10 sec)
                IDs 1000-2000 ... Done (3.42 sec)
                IDs 2000-3000 ... Done (3.36 sec)
                IDs 3000-3882 ... Done (2.81 sec)
                Building Search Index Visitor Messages: Done
                Building Search Index Blog Comments ...
                IDs 0-1000 ... Done (0.85 sec)
                IDs 1000-2000 ... Done (1.13 sec)
                IDs 2000-3000 ... Done (3.13 sec)
                IDs 3000-3345 ... Done (0.83 sec)
                Building Search Index Blog Comments: Done
                Building Search Index Blog Entries ...
                IDs 0-1000 ... Done (2.89 sec)
                IDs 1000-1265 ... Done (0.94 sec)
                Building Search Index Blog Entries: Done
                Building Search Index: 2 hours, 22 minutes and 35 seconds
                [[email protected]]#
                Originally posted by In vBulletin ACP
                VB ACP -> Maintenance -> Repair / Optimize Tables -> Select POST table -> Continue
                post Check Status: OK
                post Optimize Status: OK

                VB ACP -> Maintenance -> Repair / Optimize Tables -> Select all thread tables -> Continue
                thread Check Status: OK
                thread Optimize Status: OK
                thread_serviceupdate Check Status: OK
                thread_serviceupdate Optimize Note: Table does not support optimize, doing recreate + analyze instead
                thread_serviceupdate Optimize Status: OK
                threadrate Check Status: OK
                threadrate Optimize Status: OK
                threadread Check Status: OK
                threadread Optimize Status: OK
                threadredirect Check Status: OK
                threadredirect Optimize Status: OK
                threadviews Check Status: OK
                threadviews Optimize Status: OK

                VB ACP -> Forums & Moderators -> Forum Blocks Manager -> Reload Block Types


                VB ACP -> Settings -> Options -> Turn Your vBulletin On and Off -> Turn site on
                This is a signature, with a picture

                sigpic

                UK Motorbike Forum

                Comment


                • #10
                  Rebuilding the search index isn't going to help with getnew searches. They work differently.

                  Have you done what I suggested in post #7?
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.6 Demo
                  AdminAmmo - My Cloud Demo

                  Comment


                  • #11
                    Originally posted by Mark.B View Post
                    Rebuilding the search index isn't going to help with getnew searches. They work differently.

                    Have you done what I suggested in post #7?

                    Yes, see comment #7.1

                    Probably worth mentioning what I said in post #4 again - things easily get lost in threads like this. This originally started as an issue with 'new posts' however I have since discovered that the entire search system is down (unless you select "show results as posts" (post #9)).

                    EDIT: Just as a preemptive measure I have re-uploaded the patch files (everything but the images and install folders) (from a new download, i.e. not using the same files I used when I uploaded as part of the upgrade)
                    Last edited by MrEyes; Sun 8th Feb '15, 7:50am.
                    This is a signature, with a picture

                    sigpic

                    UK Motorbike Forum

                    Comment


                    • #12
                      I am still having this problem too even with the fix provided by Mark.B

                      Comment


                      • #13
                        Are you set to use cookie or database read marking? The second is the better of the two. However cookie is still the default in 4.X.

                        Settings -> Options -> General Settings.

                        If you are using Cookie based read marking, then every time you logout or delete cookies for any reason then everything is marked as read. If you're inactive for 15 minutes than everything is marked as read.

                        If you use database read marking, then your read/unread status is stored for 10 days.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #14
                          Cookies based as our users hated, really hated db mode when I tried it.

                          One pattern I noticed was the url search.php?do=getnew&contenttype=vBForum_Post does not get redirected to search.php?searchid= when the problem occurs.

                          Comment


                          • #15
                            I think I may have found our problem, the browser was caching the results page (an addon), I have hacked in a header fix and so far, fingers crossed, everything will be fine.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X