Announcement

Collapse
No announcement yet.

Database error after upgradng MySQL and PHP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Paul M
    commented on 's reply
    Please re-post this as a post, not a comment, it took me a while to figure out why this thread re-appeared, others will probably be confused as well.

  • NRJ
    commented on 's reply
    Trying to upgrade 4.2.3 with php 5.4 or 5.5 but both gives the same error:

    Fatal error: Call to undefined function mysqli_init() in /home/xxxxx/public_html/forum/includes/class_core.php on line 1348

  • juggler
    replied
    Originally posted by Mark.B View Post
    4.2.2 won't work properly with php 5.5.
    I guess I misunderstood the statement "vBulletin 4.0.0 - 4.2.2 requires PHP 5.2.0 or greater," to mean that PHP 5.5 was within the range. What (major) issues can I expect if I stick with 4.2.2 at least until 4.2.3 comes out of Beta?

    Is there an ETA on when 4.2.3 will come out of Beta?
    Last edited by juggler; Sun 1st Feb '15, 11:52am.

    Leave a comment:


  • Mark.B
    replied
    Basically you have two choices:

    1. Upgrade vB to 4.2.3.
    2. Downgrade php to 5.4

    4.2.2 won't work properly with php 5.5.

    Leave a comment:


  • donald1234
    replied
    You will get support on here, it is your only choice if you don't want to downgrade your PHP to 5.4, although beta, it's been around for a while now and loads of people are running it with no problems, there are also some bug fixes from 4.2.2. As always make a full back up so you can revert to 4.2.2 if a major issue does occur.

    Leave a comment:


  • juggler
    replied
    I got it fixed, somewhat. I had to enable mysqli in PHP then I was able to upgrade vB to 4.2.2 and the sites came up.

    However, I'm now getting an occasional error message - "Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ..../includes/class_block.php on line 442".

    Is vB 4.2.3 Beta supported?

    Leave a comment:


  • Mark.B
    replied
    If you're running php 5.5, you should upgrade to vBulletin 4.2.3 Beta.

    vB4.2.2 is not fully compatible with php 5.5.

    Leave a comment:


  • juggler
    started a topic Database error after upgradng MySQL and PHP

    Database error after upgradng MySQL and PHP

    I'm getting database errors after upgrading PHP to 5.5.21 and MySQL to 5.5.40. I was running 4.1.2 at the time but have since uploaded 4.2.2 files attempting to do a vB upgrade but same error when I try to run upgrade.php

    Fatal error: Call to undefined function mysqli_init() in /home/.../public_html/forums/includes/class_core.php on line 1348

    Any ideas?

Related Topics

Collapse

Working...
X