Announcement

Collapse
No announcement yet.

Edit boxes empty intermittently after forum move

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Edit boxes empty intermittently after forum move

    I just moved my forums (CMS 4.2.0 PL2) onto a new server. The old server ran CentOS with PHP 5.3.3 and MySQL 5.1, the new one is Ubuntu 12.04 LTS with PHP 5.4.11 and MySQL 5.5. The move went smoothly, but after the dust settled a weird problem surfaced: more times than not – but intermittently (i.e. it sometimes works) – the edit box is empty when attempting to edit a message. Both the QuickEdit and the Advanced Edit modes are affected. When the QuickEdit box is empty, clicking on Advanced Edit never brings up the content. Further, when I am viewing a thread, and click on "Edit Post" on various messages I have written (both before and after the move), some show up in the Edit box, others don't.

    Also the blog posts are affected. In fact they don't appear to show up for editing at all.

    If I write something in the empty edit box and save it, the original contents of the message are overwritten.

    Tried to look through MySQL and PHP parameters as well as vB settings, but didn't see anything obvious that could cause this. I didn't upgrade vB during the move; database was moved via mysqldump, and content was tarred and copied to the new server. Both servers run Apache 2.2; the Apache site config was copied as-is.

    Any ideas what I might try next, or how I could debug this further (i.e. if there are no other suggestions, it would help to know what are the potential causes for this from the back-end/code-side perspective).

    Thanks!

    - - - Updated - - -

    It's also worth noting that I moved another forum (from same old system to the same new system, but it is standalone vB 4.1.0, i.e. not CMS), and it does not experience the same problem.

    - - - Updated - - -

    In another thread someone is experiencing empty edit boxes after a forum upgrade. In a response it was asked if he uses a custom theme. I use a customized theme, but switching to the default theme makes no difference with this problem.

    - - - Updated - - -

    Yet couple more pieces of info:

    "Reply With Quote" works normally on the same messages on which "Edit Post" fails.

    Switching the QuickEdit off, or turning off all Ajax features makes no difference. When the "Advanced" edit box comes up, it's similarly empty.

    - - - Updated - - -

    I looked into this further. It seems that when the editor box is working correctly, there are two calls to ajax.php. One with queryparams ?do=quickedit&p=postid, and then another for "editorswitch".

    When the edit box comes back empty, that second call to ajax.php never occurs, and the < textarea >< /textarea > tags are empty in the response.
    Come to visit My Galagzee!

  • #2
    Please keep in mind that vBulletin 4.2.0 has issues when running with PHP 5.4.x

    http://tracker.vbulletin.com/browse/VBIV-13574

    https://www.vbulletin.com/forum/show...March-1st-2012
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      Is vB 5 Connect fully 5.4 compliant? I could upgrade..
      Come to visit My Galagzee!

      Comment


      • #4
        Yes, https://www.vbulletin.com/forum/show...m-Requirements
        Please Note that vBulletin 5 Connect now in BETA and not fully supported

        Former vBulletin Support Staff
        Need Help?, Or P.M. Me

        Comment


        • #5
          Originally posted by Hartmut View Post
          Please keep in mind that vBulletin 4.2.0 has issues when running with PHP 5.4.x
          I looked at those links and it turned out that the problem was "special characters" in the messages (since I run a Finnish board, the "special characters" that aren't so special for us Finns are "ä" and "ö" ). Some shorter messages didn't contain either of those, and hence they could be edited (thus the apparent intermittency).

          The fix was found through one of the two links you posted (here). Now I don't have to downgrade to PHP 5.3, and I can wait until version 5 comes out of beta.

          Thanks for your help!
          Come to visit My Galagzee!

          Comment


          • #6
            Originally posted by Ville View Post
            The fix was found through one of the two links you posted (here).
            Same here. thank you!

            But the question is: why on earth has this not been fixed by now? I read in the other thread that it should have been fixed with 4.2.1, but this is not the case. I discovered it the hard way, AFTER moving to a server with PHP 5.4!
            fab---

            Comment


            • #7
              The "chatter" says 5.4 support may never materialize for vB 4.2.x series as IB is pushing vB5 Connect. But vB5 Connect has its own [significant] problems and it'll take a long while before the plugin support catches up with it. I would not consider upgrading to it at this point, and PHP is putting pressure from behind as 5.3 entered end of life cycle in March of this year (hence receiving only critical bug fixes until they, too, are discontinued). With the above mentioned patches 4.2.0 can be made to work with PHP 5.4, but the latest point release of 4.2.x can't (or thus far I haven't found instructions that would work).

              Rather than considering having to re-make everything anyway with Connect 5, I'm preparing to switch to XenForo that has clean, up-to-date codebase. I've been vBulletin user for over ten years, but the way IB has handled the product in the last ~two years has been really disappointing.
              Come to visit My Galagzee!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X