Announcement

Collapse
No announcement yet.

VBulletin 4 and PHP 5.4 compatibility...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] VBulletin 4 and PHP 5.4 compatibility...

    When will vBBS 4 become compatible with PHP 5.4? Just migrated to a new server that has PHP 5.4, and I am seeing numerous errors.

    Fixed the one in function.php with a hack I found online, but now I'm seeing this one:

    Code:
    Warning: Illegal string offset 'link' in [path]/includes/class_bbcode.php on line 2777
    
    Warning: Illegal string offset 'link' in [path]/includes/class_bbcode.php on line 2791
    Saw a reference to turning off PHP warnings... clue on how to do this?

    Also saw a reference to using an .htaccess file entry to help? Any clue?

    HELP!

  • #2
    Can you downgrade your PHP to atleast 5.3.x?

    Concerning this topic, here:

    https://www.vbulletin.com/forum/show...March-1st-2012)

    you will find a thread with more informations.
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      Nope... I don't have that control over my server's configuration. Seems ridiculous to have to downgrade...

      Finally found the 500+ pst thread, thanks. I will read it.

      Comment


      • #4
        Originally posted by LOCO.MTB View Post
        When will vBBS 4 become compatible with PHP 5.4?
        http://tracker.vbulletin.com/browse/VBIV-13574
        Baby, I was born this way

        Comment


        • #5
          Unfortunately that JIRA link now only shows PERMISSION VIOLATION, and unfortunately after reviewing the code for vB 4.2.1 (implied heavily as the fix release in http://www.vbulletin.com/forum/forum...st-2012/page35), I see that not much progress has been made on the PHP 5.4 front after over year.
          Last edited by thincom2000; Mon 15 Apr '13, 8:25am.
          - the makers of VaultWiki

          Comment

          Related Topics

          Collapse

          Working...
          X