Announcement

Collapse
No announcement yet.

Warning at top of Index Page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning at top of Index Page

    http://realfamilycooking.co.uk

    If you click on 'Advanced Search' on the front index page, the following is showing at the top of the page:

    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261

    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337

    What's causing it and how do I stop it ?

  • #2
    Put this at the top of your config.php under <?php tag:
    define('SKIP_ALL_ERRORS', true);

    Comment


    • #3
      Thank you so much starme - that worked a treat.

      Comment


      • #4
        No problem. Im happy to help.
        I believe this error will be fixed on the release of vb 4.2.3
        That code will simply hide the errors

        Comment


        • #5
          I've bought V5 but don't know how to upload it to vps via plesk as it says on the V5 install page:
          vBulletin 5 Requires URL Rewriting. This will be mod_rewrite or its equivalent under Apache and URL Rewrite under IIS. There is an .htaccess (Apache) file and web.config (IIS) included in the upload folder for this purpose. The software will not work without URL Rewriting.

          And I haven't a clue what any of that means.

          Comment


          • #6
            You can test your servers compatibility with this test script.

            www.vbulletin.com/go/test

            Comment


            • #7
              As of vBulletin 4.2.2 we’ve stopped suppressing notices and warnings. This is a change from all previous versions of the software.

              In some environments more notices/warnings show than in others. In order to address the issue you just need to add the following line to your config.php file
              define('SKIP_ALL_ERRORS', true);

              You can see additional information about this change here: http://www.vbulletin.com/forum/forum...-been-released

              Bengie, it looks like you're trying to install vBulletin 4, and not 5.

              Comment


              • #8
                Sorry Zachery, two subjects in the one thread always makes them hard to understand.

                I do have 4 installed and successfully. I have bought 5 but my host cannot as yet support it, (I'm moving host at the moment). When I took a look at the 'how to install vb5' thread on here, those red lines are at the very top of the page and as I said, I haven't a clue what that means.
                I'm well into my 70s now so most of this is foreign to me and at this age it gets harder to learn things. But I will persevere and eventually get vb5 installed and running.

                It's a shame there isn't a paid service where your team can do the install for customers.

                Comment


                • #9
                  Originally posted by Bengie View Post
                  It's a shame there isn't a paid service where your team can do the install for customers.
                  There is, and always has been, a paid installation option available.

                  Baby, I was born this way

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X