Announcement

Collapse
No announcement yet.

VB 4.2.2 PL3 for earlier versions?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sticky
    commented on 's reply
    I'm hiring someone to do so. If you would tell me what files I need to look at I'm sure I could merge them in. It's that simple isn't it?

  • Paul M
    replied
    Originally posted by sticky View Post
    I don't want to upgrade. I shouldn't be forced to in order to get a patch.
    No one is forcing you - but if you choose not to upgrade then you have to take the consequences.
    Security patches for vB4 are only going to be released for the latest version, which is currently 4.2.2.

    So you must either upgrade, or if you refuse, manually diff the files and apply the changes yourself.

    Leave a comment:


  • Zachery
    replied
    If you're taking the time to actually modify the php files you should be able to diff the new files against your current batch and merge the newer changes.

    Leave a comment:


  • Mark.B
    replied
    If you want to be fully secure, you need to run the latest version of your branch.
    This is standard practice in software development. We cannot support multiple obsolete versions.

    Upgrading is still possible with modified php files, I have about 30 modified files in total and I'm running 4.2.2 - you just need to use a compare utility, and make sure you've marked or logged all the changes.

    Leave a comment:


  • sticky
    replied
    I don't want to upgrade. I shouldn't be forced to in order to get a patch.

    I have modified the php files. Are you telling me you are forcing me to upgrade and hire a programmer rather than telling me what I need to fix in 4.2.1?

    Leave a comment:


  • Mark.B
    replied
    I'm sorry, we are not providing patches for earlier versions as they are obsolete. You should upgrade to 4.2.2. Unless you've modified the php files, you shouldn't have any difficulties with the upgrade.

    Leave a comment:


  • sticky
    started a topic VB 4.2.2 PL3 for earlier versions?

    VB 4.2.2 PL3 for earlier versions?

    Vbulletin states they discovered a CMS issue that affects all versions of the CMS publishing suite and issued a patch but only for 4.2.2.

    I don't want to to upgrade to 4.2.2 as my board is heavily customized and would prefer to just apply the patch. Why is there no patch for 4.2.1 or other versions?

Related Topics

Collapse

Working...
X