No announcement yet.

"admincp" stay's collapsed

  • Filter
  • Time
  • Show
Clear All
new posts

  • "admincp" stay's collapsed

    Hi all

    I have just upgraded my forum to v 4.2.2PL3... Since doing this if I select "expand all" in the admincp then "save pref" it appears that it is not saving, everytime I enter the "admincp" it has collapsed again... Any idea why?


  • #2
    The preference is stored in cookies. So if you have a cookie blocker, javascript blocker or you logout, the preferences will not be saved or will be deleted. If you don't do those things, then delete the cookies for your domain and try again. They may be corrupted.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.


    • #3
      I have cleared all existing browser cache and cookies, and used a number of browsers and the all do the same, I can expand the menus, click save but they keep closing again... Never had an issue with my old 4.2.0 just since I upgraded...

      I have no blockers installed.

      I have noticed that although my version is shown as 4.2.2 PL 3 the latest version shown is 4.2.2 PL 2

      Click image for larger version

Name:	Capture.JPG
Views:	3
Size:	16.8 KB
ID:	4239790
      Last edited by stuarttunstall; Sat 27 Dec '14, 2:14am.


      • #4
        Not running anything like cloudflare, or something similar?


        • #5
          No, nothing has changed on my server apart from the vBulletin upgrade... I have tried Opera, IE11, Safari, Firefox and Chrome and non will save the expanded setting,, It worked fine before, I always had the menu expanded.

          even tried setting on my Android tablet, still the same.
          Last edited by stuarttunstall; Sat 27 Dec '14, 8:18am.


          • #6
            Have you tried reuploading the JS files again?


            • #7
              Is that the Clienscript folder? if so I am trying that now

              Just tried that, still collapses when I close the admincp


              • #8
                So, the problem is that, its not remembering which you have collapsed and not collapsed?

                Do you have a lot of third party addons?


                • #9
                  That is correct

                  I have a few addons, but nothing different to what was on in 4.2.0


                  • #10
                    I have just checked my test site which is running the same addons but vB 4.2.2 PL2 and that works OK? what is different in PL3?


                    • #11
                      Nothing in PL3 would cause this.

                      Try downloading a fresh copy of the entire 4.2.2 PL3 package, uploading it to the server, and running the upgrade script.
                      Then clear your browser cookies and cache, and restart the browser.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.6.3 Demo
                      AdminAmmo - My Cloud Demo


                      • #12
                        I will give that a try Thanks for the help ...


                        • #13
                          Try disabling your addons, via the config.php. You'll see that the AdminCP menus should disappear. I suspect if you expand them and save it'll be remembered.

                          I've seen this before, the reason it wont remember is that you're sending SO MANY cookie/headers at the same time, the webserver ignores it.


                          • #14
                            Hi Zachery

                            Thank you

                            I added the following to the config.php

                            define('DISABLE_HOOKS', true);

                            Opened the admincp, expanded and saved the expanded options... Closed the admincp, and opened it again, still expanded

                            I then removed the code define('DISABLE_HOOKS', true); from the config.php and tried the admincp again, still expanded

                            So, I cleared all browser cookies and cache and tried again, still expanded

                            It looks like the problem you suggested, not sure why it has only done this with PL3 and not with PL2 but I don't suppose I will work that out... Lol

                            Thank you for all your help, so far it seems sorted, or it has twice so far, will let you know if it decides to go back again...

                            All the best for the new year...



                            • #15
                              I will apologies now.... I have just "played" with my test site which is on PL2... I noticed that one of the menu options was closed, the Panjo menu, as soon as I expanded this and tried to save it all the menu;s collapsed and would not save... So, it is one of my addons... Just need to find which now and see if there is an update...


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.