Announcement

Collapse
No announcement yet.

Cache Issues [Resolved by web host]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Amaury25 View Post
    Ah, thank you. Two questions, though:
    1. So, in short, loading time may be a bit longer depending on the user's Internet connection. Am I understanding that correctly?
    2. In their example, they say some things like logo images don't need constant updating because it's unlikely to change on a daily basis. However, things like the index, forums, threads, user profiles and everything else that's similar do need constant updating, so what exactly is the issue going on now? I'm still not completely understanding it. They did a security update, but how is that causing the issues?
    I wish I knew. They stopped replying to me as well. I only know that option did fix my issues, but we are a smaller forum and don't use a ton of bandwidth anyway. I haven't noticed my forum being slow or images reloading like they did when I tried forcing the no-cache with .htaccess (which caused stuff like images to reload but not the pages!)

    My big question is why did they change it?

    Comment


    • #17
      One thing I noticed is that if it's 10 or more minutes, there's no problem. It's only when it's less than 10 minutes.

      For example, if I'm viewing the forum index at 4:30 PM and reload it 4:40 PM, it will load properly without me getting a cached version and having to perform a hard-refresh.
      Former vBulletin user

      Comment


      • #18
        Still having issues even with no-cache turned on. Any insight?

        Comment


        • #19
          Wow, check out the answer I got from FASTDOMAIN on this problem, I quoted Zachery in my support ticket at FASTDOMAIN

          Originally posted by Zachery View Post
          Its not a cookie issue. The problem is that your browser has been told EXPLICITLY, that it needs to cache this data for longer period of time. The browser uses the old data it was told to use by the server. This is a server issue.
          This is what FASTDOMAIN had to say on the issue:
          Though I can appreciate your frustration, I do need to reiterate that this is due to browser caching, which, as the host, we do not control. You and your browser do, or the browsers of the people visiting your site. I'm afraid that Zachary gave you incorrect and spurious information. This is not in any way connect to the cPanel security upgrades, to nothing with the host. The problem you state that you are having is a browser issue, exclusively.
          So I have had to use Add No-Cache HTTP Headers set to YES, this is of course going to cause server load issues which FASTDOMAIN is going to get mad s hell about but if they're going to play 'bury the head in the sand' and pretend nothing's wrong from their perspective what can we do!?
          sigpic

          Comment


          • #20
            "The problem is that your browser has been told EXPLICITLY,"
            I guess that your browser has been told by the server to cache this data for longer period of time.


            vB5 is unequivocally the best forum software, but not yet...

            Comment


            • #21
              Originally posted by beishe8 View Post
              "The problem is that your browser has been told EXPLICITLY,"
              I guess that your browser has been told by the server to cache this data for longer period of time.
              It don't matter what I tell my webhost mate, they're sticking to their guns and telling me it's me and the visitors to my site who are doing something wrong, just have to hope that I'm not the only one on FASTDOMAIN who is experiencing these problems, they can't keep their heads in the sand if lots of folk start reporting the same issues, but until then, I guess it's my fault!
              sigpic

              Comment


              • #22
                Originally posted by Amaury25 View Post
                Ah, thank you. Two questions, though:
                1. So, in short, loading time may be a bit longer depending on the user's Internet connection. Am I understanding that correctly?
                2. In their example, they say some things like logo images don't need constant updating because it's unlikely to change on a daily basis. However, things like the index, forums, threads, user profiles and everything else that's similar do need constant updating, so what exactly is the issue going on now? I'm still not completely understanding it. They did a security update, but how is that causing the issues?
                yes page loading time longer + web server's resources used higher

                As there's several web hosts mentioned in this thread the reason could be different for each but for yours with bluehost if they enabled mod_cache then that could be one reason for the problem. Mod_cache helps reduce server loads and side effect is faster page loads - they may want to do this for shared hosting so they can crowd more accounts on each server and/or allow each shared account better performance. But you mentioned you're a dedicated server owner and so should be able to disable mod_cache yourself if you have ssh root access and access apache httpd.conf to disable mod_cache as outlined at http://httpd.apache.org/docs/2.2/mod/mod_cache.html. You would need to ask your web host to disable mod_cache on your dedicated server if it is currently enabled. Shared hosting users won't have the ability though.

                Originally posted by Kajouka View Post
                I wish I knew. They stopped replying to me as well. I only know that option did fix my issues, but we are a smaller forum and don't use a ton of bandwidth anyway. I haven't noticed my forum being slow or images reloading like they did when I tried forcing the no-cache with .htaccess (which caused stuff like images to reload but not the pages!)

                My big question is why did they change it?
                see above for some reasons i already mentioned.

                You can see the effects on end user end of disabling cache no-cache if you use firefox or chrome browsers, install firebug extension for those browsers and open up firebug go to network tab



                then on bottom right corner hit settings wheel and check box the disable cache setting but leave firebug open and refresh or navigate your web site/forum with firebug open, every web site file request will have all caching at browser level disabled



                after testing you can uncheck disabel cache and close firebug window

                Originally posted by Amaury25 View Post
                One thing I noticed is that if it's 10 or more minutes, there's no problem. It's only when it's less than 10 minutes.

                For example, if I'm viewing the forum index at 4:30 PM and reload it 4:40 PM, it will load properly without me getting a cached version and having to perform a hard-refresh.
                they probably set mod_cache expire time to 600 seconds as per http://httpd.apache.org/docs/2.2/mod/mod_cache.html - it could be beneficial on dedicated servers to even leave it enabled but reduce time out i.e. 10-20 seconds

                Originally posted by Mistamike17 View Post
                Still having issues even with no-cache turned on. Any insight?
                different web host ? or could be something else. who is your web host and what have they to say about the issue ?

                Originally posted by Kirk Fitzgerald View Post
                Wow, check out the answer I got from FASTDOMAIN on this problem, I quoted Zachery in my support ticket at FASTDOMAIN

                This is what FASTDOMAIN had to say on the issue:

                So I have had to use Add No-Cache HTTP Headers set to YES, this is of course going to cause server load issues which FASTDOMAIN is going to get mad s hell about but if they're going to play 'bury the head in the sand' and pretend nothing's wrong from their perspective what can we do!?
                shared hosting or dedicated server ? shared hosting would be that they have the server control to tell the browser what to cache while dedicated server you can alter than control

                Originally posted by beishe8 View Post
                "The problem is that your browser has been told EXPLICITLY,"
                I guess that your browser has been told by the server to cache this data for longer period of time.
                exactly..
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #23
                  I sent hostmonster the comment about the mod_cache setting and got:

                  Hello,
                  I apologize for any troubles you've been having.


                  Unfortunately we are not sure of a way to resolve this.

                  Maybe you can force the browser cache to be cleared on login.
                  http://stackoverflow.com/questions/1...cache-with-php
                  Which I replied and told them meta tags and PHP do not work for this (I tried both)

                  Comment


                  • #24
                    yup read http://httpd.apache.org/docs/2.2/caching.html

                    What Can be Cached?
                    As mentioned already, the two styles of caching in Apache work differently, mod_file_cache caching maintains file contents as they were when Apache was started. When a request is made for a file that is cached by this module, it is intercepted and the cached file is served.

                    mod_cache caching on the other hand is more complex. When serving a request, if it has not been cached previously, the caching module will determine if the content is cacheable. The conditions for determining cachability of a response are;
                    1. Caching must be enabled for this URL. See the CacheEnable and CacheDisable directives.
                    2. The response must have a HTTP status code of 200, 203, 300, 301 or 410.
                    3. The request must be a HTTP GET request.
                    4. If the request contains an "Authorization:" header, the response will not be cached.
                    5. If the response contains an "Authorization:" header, it must also contain an "s-maxage", "must-revalidate" or "public" option in the "Cache-Control:" header.
                    6. If the URL included a query string (e.g. from a HTML form GET method) it will not be cached unless the response specifies an explicit expiration by including an "Expires:" header or the max-age or s-maxage directive of the "Cache-Control:" header, as per RFC2616 sections 13.9 and 13.2.1.
                    7. If the response has a status of 200 (OK), the response must also include at least one of the "Etag", "Last-Modified" or the "Expires" headers, or the max-age or s-maxage directive of the "Cache-Control:" header, unless the CacheIgnoreNoLastMod directive has been used to require otherwise.
                    8. If the response includes the "private" option in a "Cache-Control:" header, it will not be stored unless the CacheStorePrivate has been used to require otherwise.
                    9. Likewise, if the response includes the "no-store" option in a "Cache-Control:" header, it will not be stored unless the CacheStoreNoStore has been used.
                    10. A response will not be stored if it includes a "Vary:" header containing the match-all "*".



                    What Should Not be Cached?
                    In short, any content which is highly time-sensitive, or which varies depending on the particulars of the request that are not covered by HTTP negotiation, should not be cached.

                    If you have dynamic content which changes depending on the IP address of the requester, or changes every 5 minutes, it should almost certainly not be cached.

                    If on the other hand, the content served differs depending on the values of various HTTP headers, it might be possible to cache it intelligently through the use of a "Vary" header.
                    There's a reason why mod_cache is disabled by default on nearly all apache server installs.

                    If it was me, personally I'd be looking for a new web host

                    edit: other option is to ask bluehost to edit their httpd.conf apache side. That is edit the apache virtualhost entry for just your account and add CacheDisable directive to your vhost so mod_cache doesn't apply to your account.
                    Last edited by George L; Fri 7 Dec '12, 5:38am.
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #25
                      Originally posted by George L View Post
                      But you mentioned you're a dedicated server owner and so should be able to disable mod_cache yourself
                      Just for the reference, and as seen by my signature, I'm only an administrator, not the owner.
                      Former vBulletin user

                      Comment


                      • #26
                        Originally posted by George L View Post
                        different web host ? or could be something else. who is your web host and what have they to say about the issue ?
                        Hostmonster shared hosting. Filed a ticket. Haven't gotten a response yet. When I called in about it, the lady said there had not been any cPanel updates in the last week that they knew of.

                        Comment


                        • #27
                          Hey guys,

                          Just got this response from the support team at Bluehost, looks positive :

                          This issue should be fixed or will be within the next few hours. This wasn't an issue with mod_cache but likely an issue with mod_expires and mod_header changes that we made with a new kernal update. Those have been reverted and your site should be good shortly!

                          Comment


                          • #28
                            Originally posted by HeLLRZR View Post
                            Hey guys,

                            Just got this response from the support team at Bluehost, looks positive :

                            This issue should be fixed or will be within the next few hours. This wasn't an issue with mod_cache but likely an issue with mod_expires and mod_header changes that we made with a new kernal update. Those have been reverted and your site should be good shortly!
                            I noticed I stopped getting cached versions.
                            Former vBulletin user

                            Comment


                            • #29
                              Originally posted by HeLLRZR View Post
                              Hey guys,

                              Just got this response from the support team at Bluehost, looks positive :

                              This issue should be fixed or will be within the next few hours. This wasn't an issue with mod_cache but likely an issue with mod_expires and mod_header changes that we made with a new kernal update. Those have been reverted and your site should be good shortly!
                              Thats exactly what I said it was too

                              Comment


                              • #30
                                Originally posted by Zachery View Post
                                Thats exactly what I said it was too
                                Can you mark this as resolved now, Zach?

                                Thanks.
                                Former vBulletin user

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X