Announcement

Collapse
No announcement yet.

Error #2038 type = “ioError” When uploading custom files or images

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error #2038 type = “ioError” When uploading custom files or images

    Hello,

    We have enabled a custom file type (.algo) on our forum. A moderator today posted that they could not upload a .algo attachment. I've checked the permissions to ensure all users can upload this file type. I haven't run into the issue yet myself - but several of our other moderators let me know that they occasionally run into this issue too - they just keep trying and it eventually works - or they try the Basic Uploader. However, this user has tried multiple times and can't get the attachment to upload. The file size is less than our max allowed size.

    In terms of other checks:

    Attachments are saved to a database.
    We host our own server.
    Diagnostics check displays:
    • file_uploads: On
    • open_basedir: None
    • safe_mode: Off
    • upload_tmp_dir: C:\WINDOWS\Temp
    • upload_max_filesize: 2.00 MB

    Asset Manager is enabled - with Flash Upload by default selected.

    I've tried to search other posts, but what seemed different about our issue was that it was sporadic...here's a quote from one of our moderators: "The upload function can sometimes be a bit picky and it takes a couple times to actually get it to upload. I have run into this several times when posting JPG images to the various forum topics."

    Other posts have mentioned the CHMOD or 777 folder and I am unsure what that means.

    Any suggestions would be greatly appreciated!

    Thanks!
    Lori

  • #2
    There is normally one more set of numbers, with that error you're getting. What is it?

    Comment


    • #3
      Hi,

      The full error is:
      [IOErrorEvent type=ioError" bubbles=false
      cancellable=false eventPhase=2 trext="Error #2038"]


      (I just received this error too.) I told the user to turn off Enhancement Attachment Uploading in his profile - now when uploading a file, he gets the following database error:

      Click image for larger version

Name:	database error.png
Views:	1
Size:	76.2 KB
ID:	3690765

      I also received the database error when turning off the setting.

      I just got another email saying he's now unable to upload any files - an error says "Your page is blocked due to a security policy that prohibits access to Category default." Should I have him re-enable Enhancement Attachment Uploading?

      Thanks!
      Lori

      - - - Updated - - -

      Also, when we try the basic uploader, we get this message:

      The connection was reset

      The connection to the server was reset while the page was loading.
      • The site could be temporarily unavailable or too busy. Try again in a few moments.
      • If you are unable to load any pages, check your computer's network connection.
      • If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.


      I am still wondering why its only with some attachments?

      Comment


      • #5
        No, there isn't...attached is a screenshot with the message available:

        Click image for larger version

Name:	Full Error message.jpg
Views:	1
Size:	74.7 KB
ID:	3690766

        When trying to upload the same file, sometimes the red circle hover just says "upload of file failed", instead of displaying the above error.

        Thanks!
        Lori

        Comment


        • #6
          First things first, the error is just a generic error for "we couldn't upload the file".

          Now we need to find out why, can you upload the same style of algo files in the AdminCP > Maintenance > Diagnostics >

          Comment


          • #7
            Yes, it appears I can upload the same file that way - the results says: "No errors occurred while opening the uploaded file for reading." Here are the PHP settings:

            file_uploads: On
            open_basedir: None
            safe_mode: Off
            upload_tmp_dir: C:\WINDOWS\Temp
            upload_max_filesize: 2.00 MB

            Comment


            • #8
              Under Settings > Options > Message Attachment Settiings, can you change the asset manager to use ajax instead of flash, and try again?

              Comment


              • #9
                Sure, I just did that and saved the setting. When I uploaded the same attachment, I received a popup message saying the upload failed. Here is a screenshot:

                Click image for larger version

Name:	Ajax Upload Error.gif
Views:	1
Size:	25.9 KB
ID:	3690786

                Thanks!
                Lori

                Comment


                • #10
                  How are you storing your attachments, in the file system, or in the database?

                  Comment


                  • #11
                    In the database. Thanks!

                    Comment


                    • #12
                      Its really weird that both the ajax and flash uploads are being blocked. Are there any firewalls blocking anything that might be coming in?

                      Comment


                      • #13
                        it's all over port 80 - http and port 443 - https.

                        I've attached the database error emails we are getting in a text file.


                        - - - Updated - - -

                        are there other ports that attachment uploads would be coming from? We do have firewalls in place - but if the uploads come in on 80 or 443, it should be fine.

                        - - - Updated - - -

                        actually, I meant to say I can attach the text file - but then I realized, it doesn't look like you can attach text files - so not sure how to get the information to you...

                        Comment


                        • #15
                          Hi Trevor/Zachery, I've been working with osstradingtech on this issue as well.

                          All I'm seeing the <servername>.err logs are startup/shutdown messages. Same in the application log in the event viewer.

                          Also, could you please confirm the question about ports that was put forward in the previous post?

                          Thanks,

                          Matt

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X