Announcement

Collapse
No announcement yet.

Converted From SMF - Problem with Quote Marks

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Converted From SMF - Problem with Quote Marks

    I recently converted a long standing website from SMF2 with a TinyPortal CMS over to vBulletin. Most every thing went smoothly, but I have a lingering issue I can't figure out.

    In posts, signatures, etc. anyplace there is a converted over single quote or double quote mark, it shows the code &#039 ; (without the space) or & quot (also without the space) instead.

    You can see an example here: http://www.lcjs.org/showthread.php?2...Lift-Questions

    I am guessing it is the encoding from the conversion (which shows the collation as latin1_swedish_ci) and I either need to change that or do some kind of find/change in the database but I am at a loss for how to do either and know I am not going to screw up the whole board.

    Any advice is greatly appreciated!

    - - - Updated - - -

    I did find a way to change my default collation to utf8_general_ci for all my tables, but that didn't make a difference fyi!

  • #2
    Well, in impex folder there is tools folder and there is file named cleaner.php , if you have some knowledge of PHP then you can use it running that cleaner.php will replace all those words or sign with anything you want.
    Shayari | Indian Forums - Indian Community

    Comment


    • #3
      I am looking at that now, thank you! Hopefully I get it right and yes I did backup the database first!

      - - - Updated - - -

      I am struggling a bit with the configuration portion.
      I set these parameters:
      Code:
      # Replace 'Find me' and "Replace with me" with the strings  you want replaced i.e
       "'"             =>           "'"
       """             =>           """
      # add as many elements to the array as needed
      I the uploaded cleaner.php and ran it by calling it from a web address and got this error:
      Parse error: syntax error, unexpected T_DOUBLE_ARROW in /home/lcjssorg/public_html/cleaner.php on line 45

      - - - Updated - - -

      I did some more digging and found this thread: https://www.vbulletin.com/forum/show...hp-doesn-t-run
      That showed me where I was making a complete configuration error because I am php-dumb.

      So, I fixed that and reuploaded the file and ran it again and now I get a whote screen with the words "Not Active"

      I checked and the changes haven't been made so now I am lost again.

      - - - Updated - - -

      I did a bunch more digging and actually got it to run and set it to run just against the signatures and got this returned:
      Signature done -> 1
      Signature done -> 3
      Signature done -> 4
      Signature done -> 5
      Signature done -> 6
      Signature done -> 7
      Signature done -> 8
      Signature done -> 9
      Signature done -> 10
      etc etc upto 458

      But... the change didn;t happen in the signatures....anyone have any ideas?

      - - - Updated - - -

      Well damn - I found you have to clear the signature cache and then it shows up correct. But, now I have another problem!!!!

      I ran the changes as specified - or at least I thought I did. My " marks all show up correct but I get this for single quotes: I\'ve

      Can someone please tell me what to put into cleaner in this line so it fixes this?

      Code:
      $replacer = array(
                  "x"    => "y",
      where x is what I need to enter to select \' and y is what I need to enter to output '

      Comment


      • #4
        I still need help!

        Comment


        • #5
          That shouldn't be hard, first of all, have you set, for example if you want sig only to get converted then :
          $do_sigs = false;
          To :
          $do_sigs = true;

          And replace should look like (I have not tested but it should work).
          Code:
          $replacer = array(
                      "'"    => "'",
                       "&quot" => "\""
          );
          Also, I am not regular to Vb forums, you should open ticket as support forum are very not very supportive.. lols.. I know from many years..
          Shayari | Indian Forums - Indian Community

          Comment

          Related Topics

          Collapse

          • MajorKokosnuss
            Signature
            by MajorKokosnuss
            My Signature system is not working

            If i tick the "Show Signature" Box it just untick after i saved it and nothing will be shown :c

            Can someone help me ?
            ...
            Sat 12 Jul '14, 8:59pm
          • WhiskeyOSS
            Signature issues
            by WhiskeyOSS
            I noticed there was not a place for users to add a signature to their names I also noticed that if I go into the admin panel and try to upload a signature in this case it was a gif exactly like the one...
            Fri 14 Dec '12, 6:02pm
          Working...
          X