No announcement yet.

Fatal error: Xcache not installed in [path]/includes/class_datastore.php on line 528

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Fatal error: Xcache not installed in [path]/includes/class_datastore.php on line 528

    Just moved to a new server. Had xcache installed previously. NOT installed on new server.

    vBulletin Suite 4.2.0 PL3 with latest vBSEO.

    Cannot load the forum or the AdminCP because in both cases I get the error:

    Fatal error: Xcache not installed in [path]/includes/class_datastore.php on line 528

    From config.php:

    PHP Code:
        // Here you can configure different methods for caching datastore items.
        // vB_Datastore_Filecache  - to use includes/datastore/datastore_cache.php
        // vB_Datastore_APC - to use APC
        // vB_Datastore_XCache - to use XCache
        // vB_Datastore_Memcached - to use a Memcache server, more configuration below
    $config['Datastore']['class'] = 'vB_Datastore_Filecache';

    // ******** DATASTORE PREFIX ******
        // If you are using a PHP Caching system (APC, XCache, eAccelerator) with more
        // than one set of forums installed on your host, you *may* need to use a prefix
        // so that they do not try to use the same variable within the cache.
        // This works in a similar manner to the database table prefix.
    // $config['Datastore']['prefix'] = '';

        // It is also necessary to specify the hostname or IP address and the port the server is listening on
    $config['Datastore']['class'] = 'vB_Datastore_Memcached';
    $i = 0;
    // First Server
    $config['Misc']['memcacheserver'][$i]        = '';
    $config['Misc']['memcacheport'][$i]            = 11211;
    $config['Misc']['memcachepersistent'][$i]    = true;
    $config['Misc']['memcacheweight'][$i]        = 1;
    $config['Misc']['memcachetimeout'][$i]        = 1;
    $config['Misc']['memcacheretry_interval'][$i] = 15;
    Using vBSEO but Xcache disabled in vBSEO as well using the config file.

    Tried disabling hooks - no change.

    How do I access the forum and get around this error? And why is the error even occurring?

    - - - Updated - - -


    Tried again to disable hooks using

    PHP Code:
    in config.php

    This time I was able to load the forum and enter the AdminCP.

    I cleared the datastore by disabling and then enabling one of the installed plugins.

    Removed the disable_hooks line from config.php

    Forum is now accessible and working normally.

    Very weird....
    Psychlinks Web Services Affordable Web Design & Site Management
    Specializing in Small Businesses and vBulletin/Xenforo Forums

  • #2
    Have you checked your error logs?

    If you don't know how, contact your host.
    Former vBulletin user


    • #3
      As the OP has figured out this error was due to the datastore not being refreshed. In the future if anyone is moving a site from a server with xcache to a server without, you should disable xcache and refresh the data store BEFORE making the database copy to move.


      • #4
        This problem is back for XCache > 3.0.0 since it's now installed as a PHP extension and not a Zend extension anymore.


        Related Topics