No announcement yet.

BUG: Copy thread isn't working as expected

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] BUG: Copy thread isn't working as expected

    I have version 4.2.0 pl3, this problem did not exist in our previous 4.1.3.

    When using the Administrative drop down box and clicking Copy Thread, it does not copy as expected.

    Create a thread and add a couple inline images. The thread will be normal, it shows the images inline and NOT as attachments below the post. But after I do a Copy Thread, the images no longer are inline, they are put as attachments below the post. And where the images WERE inline, are a image attachment link to click is there instead.
    This is no good! Copy Thread should make it look exactly the same, not change how the images are attached and posted inline.

    I then tried to edit the copied thread and I couldn't make the images change to being inline again, it just didn't do it.

    I hope there is a fix for this, I tried searching but didn't find any info. How can I make copy thread work so that it actually looks the same as the thread being copied?

    This is a rather urgent problem as we tend to need to copy threads frequently and it is screwing up the formatting of threads that have pictures inline.


    - - - Updated - - -


    I just ran a couple tests, the problem happened only when posting an image from a URL and telling it to reference the file locally. It creates a tag that says "attach=config" instead of just "attach". Here is a screenshot of my copied thread, notice the previously inline image converts to a link, and the image appears in the attachment box instead.

    Attached Files

  • #2
    If you have found a bug, you need to enter it into Jira in order for the devs to look into it.!default.jspa

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help


    • #3
      OK, here it is:

      Just wondering if there was any info on the issue already that anybody knew about.


      • #4
        Actually, I believe it is working as intended. The attachment doesn't get copied over. Since the original post its attached to, isn't that actual post the attachment isn't show as a thumbnail.


        • #5
          I don't believe it is as intended, since it did the opposite in the previous version! When we used to do a Thread Copy, the copied thread would have inline pictures and look exactly like the original. Now instead of looking like a "copy", all the inline images become links and the pictures are in an "attachments" box below the post. For sure this is NOT the way it should work!

          Plus I don't think you're understanding. It works as intended (everything looks the same, inline images etc) IF the images were uploaded from computer. But if the images were used from a URL with it set to reference local, that's when the copied thread screws it up and doesn't attach inline like the original.

          If this were intended, why does it work completely differently depending on which method was used to attach the images? Doesn't make sense. I still say bug.


          • #6
            Our attachment system used to be a lot less robust, it didn't show attachment thumbnails.


            • #7
              Same problem for me. I make posts in a private forum and then when I finish it some days later I'll move it into the general forums. If you click on edit post it shows correctly in the editor. I used the upload from computer

              +1 bug

              Nothing like spending hours and days on a post only to find this crap.


              • #8
                Oh and to top it off I found that I could delete the attachment links and add the images back inline correctly. This is a real pain as the attachment manager does not show the attachment ID only the file name and the thumbnails are so small It's hard to tell which one is which. And you have to do them one by one. And then the site stopped responding when i was almost done and of course the restore content didn't work. This needs a fix!


                • #9
                  This bug is still shown as unconfirmed. Come on guys! I know that for most people it doesn't make sense to even need to copy threads in the first place, but on our forum it's actually quite common and is causing grief for the admins/mods.

                  Please drop some ants in your pants on this one!



                  • #10
                    The majority of resources are currently dedicated to vBulletin 5, this is not a critical bug, even if it was confirmed it would not be out in the next update.


                    • #11
                      Originally posted by Zachery View Post
                      The majority of resources are currently dedicated to vBulletin 5, this is not a critical bug, even if it was confirmed it would not be out in the next update.
                      Wow so the great benefit of upgrading to vb4 licensing from one year to the entire lifespan of vb4 wasn't a great benefit at all. I'm frustrated after paying for vb4 and then having to wait a year until I felt it was stable enough to use after the gold release, and now it's on the back burner.


                      • #12
                        I'm sorry you feel that way. Even if things were going as per normal, you bug wouldn't have been highly likely to have been fixed in the next immediate update.


                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.