Announcement

Collapse
No announcement yet.

When clicking "Edit post" no text shows up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] When clicking "Edit post" no text shows up

    When I click on "Edit post" the old text does not show up, what can be the problem?

    - - - Updated - - -

    Also, the wysiwyg-editor looks like this:
    http://i.imgur.com/cEEFJ.jpg

    I tried to disable AJAX but it does not make any difference.

    - - - Updated - - -

    Reverted templates didnt help.
    Last edited by Drakie; Fri 21st Sep '12, 7:12am.
    Can you believe this? The developers overlooked one of the most important features of a forum!
    VOTE HERE FOR:
    Alert/Notification when being quoted
    http://tracker.vbulletin.com/browse/VBIV-8606

  • #2
    I would try re-uploading all the files in your /clientscript/ folder to the server, looks like some ckeditor files are damaged or missing.

    Also check for "Suspect Files" in Admin CP -> Maintenance -> Diagnostics

    Comment


    • #3
      Originally posted by Joe D. View Post
      I would try re-uploading all the files in your /clientscript/ folder to the server, looks like some ckeditor files are damaged or missing.

      Also check for "Suspect Files" in Admin CP -> Maintenance -> Diagnostics
      Thanks for your reply. Replacing those files did nothing. I did also run the diagnostics and it told me that it did expect "4.2.0 files" and not "4.2.0 Patch level 2" even when I've upgraded!
      So I uploaded all files again and was about to run the upgrade.php when this was on top of the site:
      Code:
      Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_core.php on line 3314
      
      Warning: Cannot modify header information - headers already sent by (output started at /home/someusername/domains/*******.com/public_html/includes/class_core.php:3314) in /home/someusername/domains/*******.com/public_html/install/includes/class_upgrade_ajax.php on line 668
      
      
      Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in /home/someusername/domains/*******.com/public_html/includes/class_dbalter.php on line 882
      
      
      Strict Standards: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in /home/someusername/domains/*******.com/public_html/includes/class_dbalter.php on line 882
      
      
      Strict Standards: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in /home/someusername/domains/*******.com/public_html/includes/class_dbalter.php on line 882
      
      
      Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field() in /home/someusername/domains/*******.com/public_html/includes/class_dbalter.php on line 882
      
      
      Strict Standards: Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query() in /home/someusername/domains/*******.com/public_html/includes/class_dbalter.php on line 882
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::return_data() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_upgrade_product.php on line 182
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 499
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 89
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 503
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::return_data() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_upgrade_product.php on line 182
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 499
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 89
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 503
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::return_data() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_upgrade_product.php on line 182
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 499
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 89
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 503
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::return_data() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_upgrade_product.php on line 182
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 499
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 89
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 503
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::return_data() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_upgrade_product.php on line 182
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::build() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 499
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 89
      
      
      Strict Standards: Non-static method vB_Bitfield_Builder::init() should not be called statically, assuming $this from incompatible context in /home/someusername/domains/*******.com/public_html/includes/class_bitfield_builder.php on line 503
      
      
      Warning: Cannot modify header information - headers already sent by (output started at /home/someusername/domains/*******.com/public_html/includes/class_core.php:3314) in /home/someusername/domains/*******.com/public_html/install/includes/class_upgrade_ajax.php on line 744
      
      
      Warning: Cannot modify header information - headers already sent by (output started at /home/someusername/domains/*******.com/public_html/includes/class_core.php:3314) in /home/someusername/domains/*******.com/public_html/install/includes/class_upgrade_ajax.php on line 745
      
      ..............
      ........
      ....
      ...
      .
      more lines like this
      What to do now?

      - - - Updated - - -

      I added "ini_set("display_errors", "0");" to init.php and now there's "only" 3 errors left:

      Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in /home/somestring/domains/domains.com/public_html/includes/class_core.php on line 3314


      Warning: Cannot modify header information - headers already sent by (output started at /home/somestring/domains/domains.com/public_html/includes/class_core.php:3314) in /home/somestring/domains/domains.com/public_html/install/includes/class_upgrade_ajax.php on line 744


      Warning: Cannot modify header information - headers already sent by (output started at /home/somestring/domains/domains.com/public_html/includes/class_core.php:3314) in /home/somestring/domains/domains.com/public_html/install/includes/class_upgrade_ajax.php on line 745
      - - - Updated - - -

      Ok, I did comment out line 25 in init.php and ran the upgrade.

      In the diagnostics, can I delete all the files where is says that vb doesnt recognize them:
      http://i.imgur.com/knccb.jpg
      Can you believe this? The developers overlooked one of the most important features of a forum!
      VOTE HERE FOR:
      Alert/Notification when being quoted
      http://tracker.vbulletin.com/browse/VBIV-8606

      Comment


      • #4
        If you don't have any 3rd party add-ons (mods) then you can safely delete files VB does not recognize. Personally I would download a backup of each just in case there was something I forgot about but vBulletin itself won't be looking for those files.

        What version of PHP is running on your server? You can see the PHP version when you log into the Admin CP.

        Comment


        • #5
          Hi,

          got the same issue. I replaced the whole http stuff with vanilla files - still the same problem. The editorbox is just empty ;(
          I checked the db - everything was fine.
          Would be nice, if we can find a QUICK solution, since the update renders the cms, forum and so on unuseable.
          By now I did a rollback, but i got 2 testservers running with that problem.

          php version: 5.4.6-1ubuntu1.1 (default in ubuntu server (quantal), stable).


          greets, Nik
          Paul M. 14.12.2012: You already know vB4 isnt being worked on atm, so of course no bugs are going to have been fixed in the last few months, nor are they going to get fixed "now".

          Comment


          • #6
            Originally posted by Niktator View Post
            Hi,

            got the same issue. I replaced the whole http stuff with vanilla files - still the same problem. The editorbox is just empty ;(
            I checked the db - everything was fine.
            Would be nice, if we can find a QUICK solution, since the update renders the cms, forum and so on unuseable.
            By now I did a rollback, but i got 2 testservers running with that problem.

            php version: 5.4.6-1ubuntu1.1 (default in ubuntu server (quantal), stable).


            greets, Nik
            vBulletin 4.x is not yet compatible with PHP 5.4. Please change to PHP 5.3.x.

            Comment


            • #7
              Thanks for your answer. Even if I don`t like the reason/solution.
              Will 4.2.1 have php5.4 support?


              greets, Nik
              Paul M. 14.12.2012: You already know vB4 isnt being worked on atm, so of course no bugs are going to have been fixed in the last few months, nor are they going to get fixed "now".

              Comment


              • #8
                Not sure yet if it will be in 4.2.1 or not at this point, but it will be added to 4.x at some point.

                Comment


                • #9
                  Look here hxxp://tracker.vbulletin.com/browse/VBIV-15496

                  thats is a short Fix!

                  Comment


                  • #10
                    Originally posted by the_condor View Post
                    Look here hxxp://tracker.vbulletin.com/browse/VBIV-15496

                    thats is a short Fix!
                    Clean and easy fix! Thanks for pointing me in the right direction.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X