Announcement

Collapse
No announcement yet.

"Current Password" fields missing on EditPassword page?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Current Password" fields missing on EditPassword page?

    Hi all,

    Weird issue that I'm experiencing. Some users are having an issue being able to change their password. When they go to the "Edit Password" page, the Current Password fields are all missing. I've set their style to the default vBulletin style thinking that maybe it was a style issue but alas it doesn't appear there either. I'm not sure how to troubleshoot this?

    Please see the images below -- the user gave me permission to log into his account so I could try troubleshooting.

  • #2
    What URL is this?
    It should be: profile.php?do=editpassword
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Yessir - this is while viewing the forums/profile.php?do=editpassword

      Comment


      • #4
        In your browser view the HTML source of the page.

        Then press CTRL+F to bring up the "Find in Window" option

        Look for: Enter your present password to continue

        Does that show up in the HTML source? If so the code is being generated but being hidden for some reason.

        Also try disabling modifications and see if the password box comes back. You can disable plugins from Admin CP -> Settings -> Options Plugin/Hook System, and turn it t No.


        Comment


        • #5
          Did the users who can't see the password change area login via Facebook Connect?

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Originally posted by Joe D. View Post
            In your browser view the HTML source of the page.

            Then press CTRL+F to bring up the "Find in Window" option

            Look for: Enter your present password to continue

            Does that show up in the HTML source? If so the code is being generated but being hidden for some reason.

            Also try disabling modifications and see if the password box comes back. You can disable plugins from Admin CP -> Settings -> Options Plugin/Hook System, and turn it t No.

            I tried searching for the HTML after disabling the plugin/hook system but alas it does not appear at all.

            Here's the small snippet of the HTML - hopefully it's OK to post this. Most noteably that the current password section looks hidden?

            Code:
            <h2 class="blockhead">Edit Email &amp; Password</h2>
                <div class="blockbody formcontrols settings_form_border">
            
                    
                        <input type="hidden" name="currentpassword" id="currentpassword" />
                    
                        
                    <h3 class="blocksubhead">Edit Password</h3>
                    <div class="section">
                        <div class="blockrow">
                            <ul class="group">
                                <li>

            Comment


            • #7
              Originally posted by Lynne View Post
              Did the users who can't see the password change area login via Facebook Connect?
              Of the two users specifically who are reporting it, one of them is Facebook connected. I tried to disconnect their account from Facebook but all it does is say that they're already registered with a username, it won't disconnect them. The other user is not facebook connected.
              Last edited by meissen; Tue 21 Oct '14, 4:22am.

              Comment


              • #8
                The weird part is that when I view my other website my modifypassword style looks identical - and both are unmodified and still stock.

                Comment


                • #9
                  Have you (or they) just tried setting a password without worrying about an old one?

                  Comment


                  • #10
                    Yes - it gives the error message that they must enter their current password to continue.

                    Comment


                    • #11
                      Are both your forums on the same server? Are they both using the same version of vB? What version of vB and PHP are they using?

                      Please don't PM or VM me for support - I only help out in the threads.
                      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                      Want help modifying your vbulletin forum? Head on over to vbulletin.org
                      If I post CSS and you don't know where it goes, throw it into the additional.css template.

                      W3Schools &lt;- awesome site for html/css help

                      Comment


                      • #12
                        Yes and yes - they're hosted on the same server running identical versions. Not identical mods, but I did turn off plugins via the Settings and it had no affect on the EditPassword page. I've only had two users report this issue, but I don't think it's that common for users to try and change their password, either. The style shows that the edit password style page has not been edited, it's still the stock unmodified version.

                        Both are running vBulletin v4.2.2, PHP 5.4.12

                        Comment


                        • #13
                          And do both have this line added to the config.php file?

                          PHP Code:
                          define('SKIP_DS_ERRORS'true); 
                          You also said both sites were unmodified and still stock and yet you just said something about plugins. Having plugins on the site means the site is not unmodified, or stock. Do you have any caching on either site via the server or modifications?

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools &lt;- awesome site for html/css help

                          Comment


                          • #14
                            Originally posted by Lynne View Post
                            And do both have this line added to the config.php file?

                            PHP Code:
                            define('SKIP_DS_ERRORS'true); 
                            You also said both sites were unmodified and still stock and yet you just said something about plugins. Having plugins on the site means the site is not unmodified, or stock. Do you have any caching on either site via the server or modifications?

                            Hi Lynne,

                            I'll have to take a look at the config file to see if it has the skip_ds_errors in there. When I said both were unmodified stock I was talking about the specific template page for the EditPassword.

                            Comment


                            • #15
                              I don't know the cause but if you want to try fixing it I would try going to the Admin CP and bringing up one of the two users who have this problem, and set a new password for them- email it to them or otherwise let them know what ti is- see if that resolves the issue.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X