Announcement

Collapse
No announcement yet.

Fatal error: Maximum execution time of 30 seconds

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Fatal error: Maximum execution time of 30 seconds

    I face this problem in my Forum when try to open forum Department


    Fatal error: Maximum execution time of 30 seconds exceeded in /home/today/public_html/vb/forumdisplay.php(1067) : eval()'d code on line 6


    but when i try to open the forum Thread it open fast without any problem




  • #2
    This sounds like a cURL timeout from your server to me. If you have access to your php.ini on your server then please open it with an editor and search for 'max_execution_time = 30'. Change it to 'max_execution_time = 60' and re-start the apache afterwards. That should fix this problem, even thou it is not a genuine vBulletin problem.
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      Originally posted by Hartmut View Post
      This sounds like a cURL timeout from your server to me. If you have access to your php.ini on your server then please open it with an editor and search for 'max_execution_time = 30'. Change it to 'max_execution_time = 60' and re-start the apache afterwards. That should fix this problem, even thou it is not a genuine vBulletin problem.

      I changed the 'max_execution_time = 3600' but i still have problem , now the page open but after 2 mints

      Comment


      • #4
        The error message still shows up? Btw, 3600 seconds is a little bit too much, 60 secs are enough for usual besides that you also need to take care for security reasons then.
        No private support, only PM me when I ask for it. Support in the forums only.

        Comment


        • #5
          : eval()'d code on line 6
          Isn't it from a modification?


          vB5 is unequivocally the best forum software, but not yet...

          Comment


          • #6
            Now The The error message not appear at all , but the page open very slooooooooooooooly

            Comment


            • #7
              Please turn off all products and set the 'max_execution_time' back to what it was before you changed it (don't forget the apache re-start). I bet this problem is caused by a plugin from some product you use.
              No private support, only PM me when I ask for it. Support in the forums only.

              Comment


              • #8
                i did every thing as you till me but the Error Message Appear Again Fatal error: Maximum execution time of 60 seconds exceeded in /home/today/public_html/vb/includes/functions.php on line 5247

                Comment


                • #9
                  Well, maybe it is the same error with execution time but now it's functions.php instead of forumdisplay.php. Line 1067 in forumdisplay.php is a hook used by some product you use... Which version of vBulletin do you use? 4.2.0 PL2?
                  No private support, only PM me when I ask for it. Support in the forums only.

                  Comment


                  • #10
                    Originally posted by Hartmut View Post
                    Well, maybe it is the same error with execution time but now it's functions.php instead of forumdisplay.php. Line 1067 in forumdisplay.php is a hook used by some product you use... Which version of vBulletin do you use? 4.2.0 PL2?

                    i'm Using only VBseo , and my version of vBulletin 4.2.0



                    - - - Updated - - -

                    http://www.today-career.com/vb/forum.php

                    Comment


                    • #11
                      Did you change anything at your forum? Or did the error just appear 'over night'?

                      If you disabled all products and the error still appears (maybe you SQL server lags?), then please start a support ticket.
                      No private support, only PM me when I ask for it. Support in the forums only.

                      Comment


                      • #12
                        vBulletin Support finish to me , so can you help me , i sill have the problem

                        Comment


                        • #13
                          Originally posted by mfetoh77 View Post
                          vBulletin Support finish to me , so can you help me , i sill have the problem


                          i'm Using only VBseo , and my version of vBulletin 4.2.0
                          Did you disable ALL plugins including vBSEO?


                          vB5 is unequivocally the best forum software, but not yet...

                          Comment


                          • #14
                            Originally posted by beishe8 View Post
                            Did you disable ALL plugins including vBSEO?
                            yes but i still have the same problem

                            Comment


                            • #15
                              waiting any one to help me in this problem

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X