Announcement

Collapse
No announcement yet.

New posts and new threads not showing on sidebar

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] New posts and new threads not showing on sidebar

    Steps:
    1. I create a new thread.
    2. I promote it to article.
    3. Keep original thread: yes
    4. Move to comments forum: no


    None of the comments show in the New Forum Posts sidebar and the thread does not show in the Forum Threads sidebar. I have them both set to pull from "All Forums". I've even changed it to cache every one minute although I usually leave it set at 5 minutes.

    Also, what is "All Comments" in the creat article settings?

  • #2
    You also needed to set All Comments to Yes. See this - https://www.vbulletin.com/forum/entr...ost-as-article

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      That did not work. Every other thread that hasn't been promoted shows the comments in the sidebar except the ones I'm promoting since upgrading to 4.2.0 the other day.

      Comment


      • #4
        After you promoted the articles, did you go to Maintenance > Clear System Cache ?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          No. I will do it now.

          Do I have to do it after each time I promote?

          - - - Updated - - -

          Clear System Cache still didn't work. My threads and posts from the promoted articles still do not appear in the sidebar. All others appear fine.

          Comment


          • #6
            Which CMS widget are you wanting the comments to show up in?

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              New Forum Posts
              Forum Threads

              Comment


              • #8
                The article is not going to show up in either of those widgets. You promoted a thread to an article. The thread is now the comment thread for the article and comment threads (and the comments/posts) don't show up in those widgets.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools <- awesome site for html/css help

                Comment


                • #9
                  But I selected to keep the original thread. Does that not mean anything?

                  Comment


                  • #10
                    No. You turned it into an article, so the thread is now a comment thread.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools <- awesome site for html/css help

                    Comment


                    • #11
                      Just FYI, for anyone looking for an answer, open up includes/block/newposts.php and delete the following code:

                      Code:
                      . ($this->registry->products['vbcms'] ? " AND info.associatedthreadid IS NULL " :  '')
                      Make sure to leave the . " at the end of that line, or you'll get PHP errors.

                      Comment


                      • findingpeace
                        findingpeace commented
                        Editing a comment
                        By the way, this is a really silly default feature to begin with. First off, they DO show up in the CMS Forum Posts widget (so it's not consistent at all). And secondly, usually the forum posts being promoted to article are really popular. So of course we'd want to see them in the sidebar.
                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X