Announcement

Collapse
No announcement yet.

Problems sending email via SMTP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Problems sending email via SMTP

    Hello,

    Is this problem about vBulletin or my domain?

    Click image for larger version

Name:	smtp_email.PNG
Views:	1
Size:	13.1 KB
ID:	3724588
















    Thanks

  • #2
    Hard to know what the issue is just from this image- if you send yourself emails from the Email Diagnostic in Admin CP -> Maintenance -> Diagnostics does it work? Any errors reported?

    Comment


    • #3
      E-mail servers does not accept my emails because of there is not information about from whom.

      Only http://10minutemail.com/10MinuteMail/index.html email server accepts.

      Forum sends the mails successfuly

      Comment


      • #4
        Well it is unlikely it is a vBulletin issue, I've never seen this happen before... But to be sure-

        Step 1) Log into your Admin CP then go to Maintenance -> Diagnostics -> Suspect File Check... Look if you have any files listed as "Does not contain expected contents" - those are files that have been altered from the default vBulletin files. If you see such files (besides index.php and/or forum.php) please try to download the vBulletin package again (for whatever version you are using) and reupload all the files to restore them to fresh files.

        Step 2) If the above doesn't help try disabling hooks as explained below to disable the plugin system and see if you still have the issue-

        To disable the plugin/hook system open your config.php which can be found in your forumroot/includes directory

        Just below
        Code:
        <?php
        enter
        Code:
        define('DISABLE_HOOKS', true);
        and save the file.

        If you would like to enable the plugin/hook system again, either remove the line again or simply comment that line out. To do so, add two forward slashes " / " so it will look like

        Code:
        // define('DISABLE_HOOKS', true);
        Next time you would like to disable the plugin/hook system again
        you simply have to remove the " // ".

        If after both of the above you still have the issue I would say it is a problem with the mail server- I'm 90% sure it is already since email works when you use Gmail, but these steps will bring the certainty up to 99%.

        Comment


        • #5
          Hello,

          OK, define('DISABLE_HOOKS', true);

          Note: index.php AND forum.php I delete AND re-uploading
          Click image for larger version

Name:	1347060810166-uploadscreenshot-dot-com.jpg
Views:	1
Size:	42.7 KB
ID:	3690214

          Click image for larger version

Name:	aaaaaaa.PNG
Views:	1
Size:	12.6 KB
ID:	3690215

          AND
          Result MISSING_DOMAIN

          Comment


          • #6
            And if you use Google's SMTP settings it works...

            I would say you've narrowed it down to an issue with your mail server then.

            Comment


            • #7
              But, joomla no problem does not exist

              There may be a problem with the vBulletin?

              Comment


              • #8
                Well with no add-ons enabled and with a fresh copy of the files it is still happening, but I have never seen it happen to anyone else- indeed a google search of "missing_domain" and email on vbulletin.com turns up only this thread in the many years worth of past issues- so that is my basis for why I do not believe it is VB related.

                That and the fact using another email server (gmail) works properly.

                Comment


                • #9
                  @Joe D.
                  We solved this problem thanks to you

                  Thank you very much

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X