Announcement

Collapse
No announcement yet.

:81 Redirect Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] :81 Redirect Issues

    Hello everyone. Long time VB user, first time poster. I'll try to make this as detailed and coherent as possible, and start from the beginning. I would like to say I have tried searching on here but my exact issue is too small for a search field. Also, others who have had the same issue never posted their results (at least not in the googling I did)

    I used to run a forum a few years ago. I deleted the forum thinking I was done and over with it. Last night I tried a fresh install on a new webhost. Everything went swimmingly (Save for some headscratching as I tried to remember how to do a few things :P )

    After the site finished installing, everything seemed fine. No issues.

    After I got into admincp, I started noticing the problem

    Every redirect will automatically insert a :81, which I can only assume means port 81. To clarify, the following issue happens. type in http://www.example.com, it redirects to http://www.example.com:81/example

    Whenever a redirect happens, it'll automatically go to the Thank You, Please Hold screen for the redirect. Then it pops out an error due to the :81 being there.

    What I have tried:


    I've gone through the Login/URL/ Contact area. I made sure there was no random letter inside. Nothing there seemed to be out of place.

    I checked my config.php and made sure all of that was fine and dandy. Didn't see a problem.

    I've seen someone mention the .htaccess file, but it's been so long I'm not sure where that would be located; I feel like a newbie all over again.


    If you have a link to another related article, that would be appreciated as well. I did scouring last night but it was pretty late. I might have looked right over it.


    Anywho! Thanks for your time. Hope everyone's having an awesome weekend!

    Nathan "Scott" Stinson

  • #2
    This usually happens if you have the server (apache/nginx whatever) running on other ports or some http header is set wrong.

    Does urls with :81 work?

    Comment


    • #3
      Unfortunately, no. Any time a redirect happens the page will fail to load. To access the admincp for example I have to physically type in the/admincp and then delete the :81 a few times.

      When you say the http header is set wrong, is it something that I should check in admincp or my cpanel?

      Comment


      • #4
        It is probably in your apache config or something. $_SERVER['SERVER_PORT'] (http header SERVER_PORT) is 81 for some reason I think.

        Comment


        • #5
          It was indeed an issue with the apache config. After reporting it to the webhost, the issue was resolved! You can mark this closed, I hope this helps someone in the future. :]

          Comment

          Related Topics

          Collapse

          Working...
          X