Announcement

Collapse
No announcement yet.

New User Moderation issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New User Moderation issue

    Hi, I upgraded from v3 to v4.2.2 and I have it set up so new registrations have to be approved by a moderator once they click the validate email link. The new user is able to validate link, and I get a notification say there is a new member, however, the user does not appear in the moderation queue. I checked this by as well by creating a few new members and they do not appear.

    Not sure what to check, any help appreciated.

  • #2
    Where is the user showing up? I mean, what usergroup are they showing up in after clicking the activation link?

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      They get approved and placed in the newbie account so they are made active without being moderated.

      Comment


      • #4
        It also does not show the newest user in the forum statistics....

        Comment


        • #5
          What option did you actually set to make members require approval?
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.6.3 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            "Moderate New Members"

            Perhaps it is they go to 'newbies' instead of registered? Although I don't remember changing that...

            Comment


            • #7
              The usergroups used are hard coded, so you'd need to make sure you are using the correct groups, regardless of what you have renamed them to.

              In vB4 it's usergroupid 4 that members go into when awaiting your approval. By default this is called "Users Awaiting Moderation".
              You need to make sure that your usergroup for this purpose is usergroupid 4.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.6.3 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Mark, do I have to set that somewhere? I did not alter anything when I upgraded, just made 'newbies' people with less than 10 posts.....

                Edit, this is set at 4...
                COPPA) Users Awaiting Moderation

                Comment


                • #9
                  You get the email notification that a new user has registered when they registered. Not when they verify their email.

                  Comment


                  • #10
                    The issue is not an email I receive, it is they do not show up in moderation once they verify. I have created a few test accounts, clicked on the confirmation email, then when log in as admin via admincp the user is not in moderation, but is active.

                    Comment


                    • #11
                      Are you sure you have user moderation turned on then?

                      Comment


                      • #12
                        Originally posted by Zachery View Post
                        Are you sure you have user moderation turned on then?
                        Yep, have had this set up for many years, but seems something happened with the upgrade.

                        Comment


                        • #13
                          Originally posted by shadey View Post
                          Mark, do I have to set that somewhere? I did not alter anything when I upgraded, just made 'newbies' people with less than 10 posts.....

                          Edit, this is set at 4...
                          COPPA) Users Awaiting Moderation
                          I'm not sure what you mean here. Can we get a screen cap of your Usergroup Manager so we can see the usergroup ids for the usergroups.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools <- awesome site for html/css help

                          Comment


                          • #14
                            This is how it looks.

                            Comment


                            • #15
                              I can barely make those out.

                              Probably best to log a ticket so we can take a closer look...we'll need AdminCP and FTP access:
                              http://www.vbulletin.com/go/techsupport
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.3 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X