Announcement

Collapse
No announcement yet.

Still invalid redirect and login errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Still invalid redirect and login errors

    Can't explain this and looked at everything. Our site is at www.mysite.com/forums/ and when I use the login form I will frequently get this:

    Invalid Redirect URL (http://mysite.com/forums/)
    All times are GMT%1$s. The time now is %2$s.

    I pasted in the area in the footer because it should give you a better indication of where something is going wrong. If I go into the forum afterward, I am logged in. Now let's say I log out and clear cookies. I will login again and the page will appear to refresh after I'm gold by the redirection page that I am now logged in. But I'm taken back to the forumhome and I'm not logged in, just an empty form. You can try to login five times in a row and the same thing will happen and you think you're not logged in. But let's say you try to go to the forum - you'll then be logged in once you leave the forumhome page.

    I've seen others have this problem. I've removed the only 4 plugins I had and it didn't seem to make a difference. Wondering if any of you know what could be the root cause. Thank you.
    My law forum, lawyers and legal help site

  • #2
    Make sure that your "Forum URL" setting is configured correctly. (Admin CP -> Settings -> Options -> Site Name / URL / Contact Details)

    Comment


    • #3
      Originally posted by Matthew Gordon View Post
      Make sure that your "Forum URL" setting is configured correctly. (Admin CP -> Settings -> Options -> Site Name / URL / Contact Details)
      Matthew - Thanks for responding.

      The Forum URL in Site Name in Options: http://www.mysite.com/forums

      I've tried to use the Forum Component URL to, which was blank and I've also tried pasting in the same URL as this one. I still get that odd message on occasion of the URL error without the www.

      Neither of the above options work. It's really bizarre. When you login to the forum on the forumhome, you get redirected, get back to the home page and you're not logged in. But if you go to any forum - once you do - you realize that you're logged in!
      My law forum, lawyers and legal help site

      Comment


      • #4
        Slinky you should not enter in anything under Forum/CMS/Blog Component URL - You only need to set the base path i.e. "Always use Forum URL as Base Path" should be set to Yes and so long as the Forum URL is correct you should be good to go!


        Former vBulletin Support Staff
        Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
        Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X