Announcement

Collapse
No announcement yet.

vbulletin 4.2 problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] vbulletin 4.2 problems

    Hello,

    Sometimes i have this error messages:

    Warning: Illegal string offset 'link' in [path]/includes/class_bbcode.php on line 2777

    Warning: Illegal string offset 'link' in [path]/includes/class_bbcode.php on line 2791


    i have duplicated posts too and other issues... it happens after server upgrade:


    Tipo de Servidor FreeBSD Usuários a Moderar 0 [Ver]
    Servidor Web Apache v2.2.22 Tópicos a Moderar 0 [Ver]
    PHP 5.4.4 Posts a Moderar 0 [Ver]
    Tamanho Máximo para PHP Post 32.00 MB Anexos a Moderar 0 [Ver]
    Tamanho Máximo de Upload para o PHP 32.00 MB Eventos a Moderar 0 [Ver]
    Limite de Memória para o PHP Nenhum Number of Queued E-Mails 0
    Versão do MySQL 5.5.25
    Tamanho do Pacote MySQL 1.00 MB


    Thanks!

  • #2
    Glad i seen this..I am getting this too, same exact error?

    Only seems to be on posts that have inline images

    - - - Updated - - -

    I turned off thumbnail view of inline images, changed to full size, and no more error?

    So its definitely has to do with display or thumbnail pics in a thread,

    I noticed when the error does happen, there is no "X" to close the picture

    - - - Updated - - -


    I see the Op is also using PHP 5.4.4, I know its not supported...maybe the issue?

    Comment


    • #3
      php 5.4 is currently not supported, in most cases you can use it though if you turn error reporting off as most of the "errors" are just warnings and can safely be ignored.

      As for duplicate posts, that's nothing to do with php versions and is a separate issue - more details will be needed as simply upgrading the forum will not cause duplicate posts.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.4 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        similar illegal offset php errors

        We are getting similar "illegal offset errors" in our logs for a different file:
        [error] [client 208.93.143.69] PHP Warning: Illegal string offset 'enable' in /usr/local/www/apache22/vhosts/dailyfx_forum/htdocs/includes/class_postbit.php on line 1095, referer...

        And these started pretty soon after going from 4.1 to 4.2, we're also running php v5.4.4.

        Is this the same problem as mention earlier ----basically we have to either turn off all php logs or just see them forever?

        d


        Originally posted by Mark.B View Post
        php 5.4 is currently not supported, in most cases you can use it though if you turn error reporting off as most of the "errors" are just warnings and can safely be ignored.

        As for duplicate posts, that's nothing to do with php versions and is a separate issue - more details will be needed as simply upgrading the forum will not cause duplicate posts.

        Comment


        • #5
          Yes, it is the same problem.

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Is there any time frame for vb support of PHP 5.4? It's frustrating to get daily error logs for this - also it's being included in standard LAMP distros, so what version are people expected to be using?


            Originally posted by Lynne View Post
            Yes, it is the same problem.

            Comment


            • #7
              Originally posted by Dan_S View Post
              Is there any time frame for vb support of PHP 5.4? It's frustrating to get daily error logs for this - also it's being included in standard LAMP distros, so what version are people expected to be using?
              No timescale has been announced as yet, however Lawrence has stated that the intention is to spport php5.4 sometime after vB5 comes out of beta and goes into Gold.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.4 Demo
              AdminAmmo - My Cloud Demo

              Comment

              Related Topics

              Collapse

              Working...
              X