Announcement

Collapse
No announcement yet.

Syntax problem when moving posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Syntax problem when moving posts

    Originally posted June 12, 2012

    Hello -
    I just got the 1064 error as well while moving a post out of a thread to a new thread. I went back to the thread to see what happened, and it had in fact moved. Not sure what the consequences, if any, of the error.

    Database error in vBulletin 4.2.0:

    Invalid SQL:
    DELETE FROM vbactivitystream
    WHERE
    typeid =
    AND
    contentid IN (SELECT postid FROM vbpost WHERE threadid IN (8351,8359));

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND
    contentid IN (SELECT postid FROM vbpost WHERE threadid IN (8351,8359))' at line 4
    Error Number : 1064
    Request Date : Monday, June 25th 2012 @ 07:42:23 AM
    Error Date : Monday, June 25th 2012 @ 07:42:23 AM
    Script : http://www.xxxxxx/forum/inlinemod.ph...&postids=14285
    Referrer : http://wwwxxxxxx/forum/inlinemod.php?threadid=8351&p=
    IP Address : nn.nn.nn.nn
    Username : me
    Classname : vB_Database
    MySQL Version : 5.0.95-community-log

    - - - Updated - - -

    Here's another:

    Database error in vBulletin 4.2.0:

    Invalid SQL:
    DELETE FROM vbactivitystream
    WHERE
    typeid =
    AND
    contentid IN (SELECT postid FROM vbpost WHERE threadid IN (8360));

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND
    contentid IN (SELECT postid FROM vbpost WHERE threadid IN (8360))' at line 4
    Error Number : 1064
    Request Date : Saturday, July 7th 2012 @ 06:51:41 AM
    Error Date : Saturday, July 7th 2012 @ 06:52:51 AM
    Script : http://www.mysite.com/forum/inlinemo...&postids=14329
    Referrer : http://www.mysite.com/forum/inlinemo...d=8351&p=14327
    IP Address : xx.xx.xx.xx
    Username : me
    Classname : vB_Database
    MySQL Version : 5.0.95-community-log


    Again, the posts moved, so it appears not to be an immediate problem, but perhaps it is just hiding one to be unleashed in the future.

  • #2
    Do you have the latest update? I think that's a bug that was fixed by one of the patches that were released.

    Comment


    • #3
      ^^ What Kevin said. The lastest version of vB4.2.0PL2 should not be giving this error.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X