Announcement

Collapse
No announcement yet.

SQL Error and I have used google and site search looking for this one

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ace
    replied
    Originally posted by jdeveaux View Post
    It dawned on me that the only plugin that does not disable when you use the VB disable plugin in the config.php file is vbSEO. DOH!
    All plugins related to all products are disabled if you disable hooks in config.php.

    vBSEO just happens to have a .htaccess file, which needs to also be disabled.

    Leave a comment:


  • jdeveaux
    replied
    Yup... Sorry for the late update. I was up late digging into it. I reloaded vbSEO and that corrected it.

    It dawned on me that the only plugin that does not disable when you use the VB disable plugin in the config.php file is vbSEO. DOH!

    Thank you for all of the help trying to figure this one out.

    I'm not sure which one of the rewrites or options was broken but the problem is now resolved and I can move on with life again.

    Again Thank You!

    Leave a comment:


  • Andy
    replied
    Seams to be working now.

    http://www.marsh-reef.org/external.php?type=RSS2

    Leave a comment:


  • jdeveaux
    replied
    Originally posted by Trevor Hannant View Post
    Is there nothing in this line of the error message?:


    MySQL Error :
    Nothing. Every single log entry is exactly the same.

    This is the error that just popped when I used the url in the error.

    Code:
    =====================================================
    
    Database error in vBulletin 4.2.0:
    
    Invalid SQL:
    
                SELECT data, expires, locktime, serialized
                FROM vb_cache
                WHERE cacheid = '';
    
    MySQL Error   : 
    Error Number  : 
    Request Date  : Monday, June 18th 2012 @ 10:22:28 PM
    Error Date    : Monday, June 18th 2012 @ 10:22:28 PM
    Script        : http://www.marsh-reef.org/external.p...p;forumids=105
    Referrer      : 
    IP Address    : 98.198.101.118
    Username      : Unregistered
    Classname     : vB_Database_MySQLi
    MySQL Version : 
    =====================================================
    - - - Updated - - -

    Originally posted by Andy View Post
    It's partially working.

    (this gives an error message)
    http://www.marsh-reef.org/external.php?type=RSS2

    (this works)
    http://www.marsh-reef.org/external.p...2&forumids=116

    It works when you select a RSS2 feed that selects a particular forum.
    I just wish I could figure out what is triggering the empty call from the first one.

    Leave a comment:


  • Andy
    replied
    It's partially working.

    (this gives an error message)
    http://www.marsh-reef.org/external.php?type=RSS2

    (this works)
    http://www.marsh-reef.org/external.p...2&forumids=116

    It works when you select a RSS2 feed that selects a particular forum.

    Leave a comment:


  • Trevor Hannant
    replied
    Is there nothing in this line of the error message?:


    MySQL Error :

    Leave a comment:


  • jdeveaux
    replied
    Still no change on my end. Could this error be caused by user requests linking to an old url that went away with the upgrade? My thought is that it may not be a problem with our system it may be that someone had linked to an RSS feed and their link is actually what is broken. The error only occurs when someone connects to the site.

    Leave a comment:


  • jdeveaux
    replied
    That's the same thing I get.

    I'll mess around with the external feed settings but my gut says the problems not there. If I could replicate the issue on my dev site life would be perfect

    Leave a comment:


  • Andy
    replied
    When I enter this into the address in Firefox "http://www.marsh-reef.org/external.php?type=RSS2", I get the following:

    Click image for larger version

Name:	Untitled-1.jpg
Views:	1
Size:	24.0 KB
ID:	3689418

    Regarding the headinclude code, that's exactly what I have in my headinclude, so that couldn't be the problem.

    - - - Updated - - -

    Here are the rss settings in my Admin CP.

    Click image for larger version

Name:	Untitled-2.jpg
Views:	1
Size:	100.4 KB
ID:	3689419

    Leave a comment:


  • jdeveaux
    replied
    Well no luck with the delete repair/optimize

    Suspect File Versions looks good ... the only thing coming back with 'File does not contain expected contents' are the .js java script files. They have always come up that way on every upgrade I've done.

    This appears obvious to me but when I execute the script listed in the error the system immediately throws and error with my IP address...
    Code:
    http://www.marsh-reef.org/external.php?type=RSS2
    feel free to run it and see the output.

    - - - Updated - - -

    I found this in my headerinclude template

    Code:
    <vb:if condition="$vboptions['externalrss']">
        <link rel="alternate" type="application/rss+xml" title="{vb:raw vboptions.bbtitle} {vb:rawphrase rss_feed}" href="{vb:raw vboptions.bburl}/external.php?type=RSS2" />
        <vb:if condition="$show['foruminfo'] OR $show['threadinfo']">
            <link rel="alternate" type="application/rss+xml" title="{vb:raw vboptions.bbtitle} - {vb:raw foruminfo.title_clean} - {vb:rawphrase rss_feed}" href="{vb:raw vboptions.bburl}/external.php?type=RSS2&amp;forumids={vb:raw foruminfo.forumid}" />
        </vb:if>
    </vb:if>
    The second line doesn't actually call anything... could that be the cause of this?

    Leave a comment:


  • Andy
    replied
    Another thing to try is the run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Leave a comment:


  • jdeveaux
    replied
    I will try that again. Last time I did it through the VB tools; I'll use the admin console in myphp this time.

    Leave a comment:


  • Andy
    replied
    Originally posted by jdeveaux View Post
    No luck. That same entry and the error came right back. Not sure if that is the problem or not now. Going to try backing out mods and see what happens.
    After deleting the offending row in the cache table, I suggest you run the repair/optimize function on the cache table.

    Leave a comment:


  • jdeveaux
    replied
    Originally posted by Ace View Post
    Does it really have no MySQL Error/Error Number details?
    Correct. Not even in the Logs. Which makes it even more annoying.

    Leave a comment:


  • Ace
    replied
    Does it really have no MySQL Error/Error Number details?

    Leave a comment:

Related Topics

Collapse

Working...
X