Announcement

Collapse
No announcement yet.

Problem with reputation after upgrade to 4.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Problem with reputation after upgrade to 4.2

    After upgrade reputation button stop working. If I open new window to add reputation(popup in new tab) and press 'Add reputation' I get this error:

    Code:
    Fatal error: Field newrepcount is not defined in $validfields in class vB_DataManager_User in [path]/includes/class_dm.php on line 515
    #0 vb_error_handler(256, Field newrepcount is not defined in $validfields in class vB_DataManager_User, /www/includes/class_dm.php 515, Array ([fieldname] => newrepcount,[value] => 1,
    [..]
    How to fix that?

  • #2
    When you upgraded did you run upgrade.php to make the database changes needed in 4.2?

    You uploaded all vBulletin 4.2 files?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Of course, and it was completed and I uploaded all files ;-) In the same time, I deleted few custom profile fields, this may be connected?

      Comment


      • #4
        No. newrepcount should be in your user table. Look at your table in phpMyAdmin. Does the field exist? It should have been added by the upgrade script.

        If it doesn't you need to add it.


        ALTER TABLE `user` ADD COLUMN `newrepcount` SMALLINT(5) UNSIGNED NOT NULL DEFAULT '0'
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          I have this table. Answer from phpmyadmin:
          Code:
          #1060 - Duplicate column name 'newrepcount'

          Comment


          • #6
            Re-upload the files then.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Thanks, problem was in custom modyfications in class_dm_user.php. Thanks, and sorry for problem. Thread closed ;]

              Comment

              Related Topics

              Collapse

              • Mevlüt Akpinar
                Error :API Error
                by Mevlüt Akpinar
                Hello,
                Etc. 5 I smoke. I do not have a shortage of time following entry but I also enter my login information (in debug mode) I get the following errors.



                Error :API E...
                Tue 22nd Dec '15, 12:42pm
              • Mevlüt Akpinar
                System Error
                by Mevlüt Akpinar
                Hello there,
                System Error Gives below.
                System Error has occurred.
                The software is Experiencing a systems error.
                You should attempt to repeat your last action. If this error occurs...
                Wed 2nd Mar '16, 11:18am
              • geovadim
                Update errors
                by geovadim
                I am trying to update my forum vb3.7 to vb5 connect. I've copied the files from vb5 in a test forum and created a copy of the live database.

                PHP Version 5.4.38

                I went to upgrade...
                Mon 2nd Mar '15, 2:18am
              Working...
              X