Announcement

Collapse
No announcement yet.

Error During Upgrade 4.1.12 -> 4.2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error During Upgrade 4.1.12 -> 4.2.0

    Received this error during upgrade... Anyone able to translate into plain English?
    This was NOT from the primary upgrade where the forum is shut down and all the files FTP'd etc. Instead, I had completed the main upgrade and was looking through my ACP when I saw a new sub-menu-item in the 'Settings' Menu. It was called "Run Upgrade Script", so I did just that by clicking it.

    My Blog & Articles have disappeared (they were gone from before this point, but were there prior to running the main upgrade) although they are present & enabled in the products menu of the ACP.




    Unexpected Text:<?xml version="1.0" encoding="windows-1252"?>
    <?xml version="1.0" encoding="windows-1252"?>
    <errors>
    <error><![CDATA[<p>Database Error</p>


    Invalid SQL:


    UPDATE vbtemplate
    SET styleid = -10 WHERE styleid = -1 AND (product = 'vbulletin' OR product = '');


    Duplicate entry 'memberinfo_block_reputation--10-template' for key 2]]></error>
    <error_html><![CDATA[<p>Database error in vBulletin 4.2.0</p>
    <p>Invalid SQL:


    UPDATE vbtemplate
    SET styleid = -10 WHERE styleid = -1 AND (product = 'vbulletin' OR product = '');<p>
    <p>
    <strong>MySQL Error</strong> : Duplicate entry 'memberinfo_block_reputation--10-template' for key 2<br />
    <strong>Error Number</strong> : 1062<br />
    <strong>Request Date</strong> : Wednesday, June 13th 2012 @ 03:13:23 PM<br />
    <strong>Error Date</strong> : Wednesday, June 13th 2012 @ 03:13:24 PM<br />
    <strong>Script</strong> : http://mydomain.com/install/upgrade.php<br />
    <strong>Referrer</strong> : http://mydomain.com/install/upgrade.php<br />
    <strong>Classname</strong> : vB_Database<br />
    <strong>MySQL Version</strong> : 5.0.95<br />
    </p>]]></error_html>
    </errors>
    VB 5.4.1 - PHP 7..2.4 - MySQL 5.5.56
    No Addons - none at all.

  • #2
    In the future, you are not supposed to click that link unless you intend to run a upgrade. If you already upgraded, no need to run that script again.

    I got your ticket, working on it now.

    Comment


    • #3
      Thanks :-)
      VB 5.4.1 - PHP 7..2.4 - MySQL 5.5.56
      No Addons - none at all.

      Comment


      • #4
        same problem happend to me plz tell us how to silve it

        Comment


        • #5
          Originally posted by youssef4 View Post
          same problem happend to me plz tell us how to silve it
          Please start your own thread, explaining the whole of your situation. It always better to start your own thread. Thanks.
          Please feel free to contact me if you have any questions or concerns

          Links: vBulletin Manual - Code Documentation - FAQ - Bug Tracker - Lemon Juice
          vBulletin 5 Connect: Extensions - Articles - Features - Purchases

          Comment


          • #6
            It is extremely unlikely you got the exact same error and what I did would only fix this one specific error. That is why your own thread with your own details is a much better option then trying to apply what I did here to your situation.

            That said in this case somehow he had two copies of the memberinfo_block_reputation template in the database with the same styleid (-10). I had to use a mysql tool (like phpmyadmin) to manually edit one of the entries styleids from -10 to -11. The upgrade then ran perfectly. When you're all done you can manually delete the template with the styleid of -11 from the database.
            Last edited by BirdOPrey5; Sun 22 Jul '12, 4:28am.

            Comment


            • #7
              Originally posted by BirdOPrey5 View Post
              It is extremely unlikely you got the exact same error
              I just got exactly the same error, but mine was due to the presence of a single template with the id -10. I changed that to -11 and the process continued.

              Thanks for the fix.
              My Live vB5 Site - NZEating.com
              vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X