Announcement

Collapse
No announcement yet.

class_bootstrap_framework.php on line 65

Collapse
X
 
  • Time
  • Show
Clear All
new posts

  • Paul M
    replied
    Originally posted by OhioScions.com
    Why should we have to perform these "work arounds" in order to properly use vB admin tools?
    Because it wouldnt work otherwise.

    Originally posted by OhioScions.com
    For the amount of money we pay, there's no concise fix.
    Yes there is, 4.2.0 PL 2 (it was actually fixed in PL 1).

    Originally posted by OhioScions.com
    It's been posted for several months now, and with all the searches I've done, this is the only one to contain some sort of "fix" for now...until who knows. Oh, I forgot...they are too busy working on #5, instead of perfecting #4.5
    Completely wrong, PL 1 was released on June 7th.

    (There is no 4.5).

    Leave a comment:


  • Zachery
    replied
    If you're running vBulletin 4.2.0 PL2, no changes should be required.

    Leave a comment:


  • OhioScions.com
    replied
    Why should we have to perform these "work arounds" in order to properly use vB admin tools? For the amount of money we pay, there's no concise fix.

    It's been posted for several months now, and with all the searches I've done, this is the only one to contain some sort of "fix" for now...until who knows. Oh, I forgot...they are too busy working on #5, instead of perfecting #4.5

    Leave a comment:


  • TheLastSuperman
    replied
    Originally posted by qpurser
    Thanks Superman for the help.
    For me the error showed up when loading the tools.php and won't let me do anything of course. Just showed an empty page with the error message
    I had the exact same issue on my localhost, brand new installation to boot so it's not related to anything being botched in the upgrade/restore process from what I can see, it could be in your case but not in mine taking that into consideration respectively.

    Here is a (Please note this is not official or supported currently) snippet of code you need to remove from class_bootstrap_framework.php:
    Code:
    // Check datastore 
    // This should be redundant as all routes are accessed via vB_Router 
    if (!sizeof($vbulletin->routes) AND VBINSTALL !== true) 
    {
        $vbulletin->datastore->fetch(array('routes')); 
    }
    You can delete that or simply add // (two / symbols) in front of the actual code to hide (comment) it out example:

    Code:
    // Check datastore 
    // This should be redundant as all routes are accessed via vB_Router 
    //if (!sizeof($vbulletin->routes) AND VBINSTALL !== true) 
    //{ 
    //    $vbulletin->datastore->fetch(array('routes')); 
    //}
    Save and re-upload the file, now run tools.php and it should work. I would also revert the file changes when done running tools.php and wiat for this to be addressed in a future version.

    Leave a comment:


  • qpurser
    replied
    Originally posted by TheLastSuperman
    The error was on the tools.php page or after you ran tools.php?
    Thanks Superman for the help.
    For me the error showed up when loading the tools.php and won't let me do anything of course. Just showed an empty page with the error message

    Leave a comment:


  • TheLastSuperman
    replied
    Originally posted by umc
    Hello People,
    I'm running the VB4.2 after i restored the database i got this error


    I ran the tools.php then i got another error

    Fatal error: Call to a member function fetch() on a non-object in /var/www/vhosts/domain.com/httpdocs/forums/includes/class_bootstrap_framework.php on line 65

    How to fix this error?

    Thank you
    The error was on the tools.php page or after you ran tools.php?

    Originally posted by qpurser
    Same issue. Got the same error message
    Need to run the tools.php to rebuild the bitfields.
    You can rebuild bitfields using the url:

    Leave a comment:


  • qpurser
    replied
    Same issue. Got the same error message
    Need to run the tools.php to rebuild the bitfields.

    Leave a comment:


  • umc
    started a topic [Forum] class_bootstrap_framework.php on line 65

    class_bootstrap_framework.php on line 65

    Hello People,
    I'm running the VB4.2 after i restored the database i got this error

    vBulletin datastore error caused by one or more of the following:
    1. You may have uploaded vBulletin files without also running the vBulletin upgrade script. If you have not run the upgrade script, do so now.
    2. The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.



    Fatal error: vBulletin datastore cache incomplete or corrupt in [path]/includes/init.php on line 252
    I ran the tools.php then i got another error

    Fatal error: Call to a member function fetch() on a non-object in /var/www/vhosts/domain.com/httpdocs/forums/includes/class_bootstrap_framework.php on line 65

    How to fix this error?

    Thank you
    Last edited by umc; Tue 5 Jun '12, 9:03am.

Related Topics

Collapse

Working...
X
😀
🥰
🤢
😎
😡
👍
👎