Announcement

Collapse
No announcement yet.

Delayed Email Notifications since upgrade to 4.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Delayed Email Notifications since upgrade to 4.2

    I upgraded to 4.2 on Friday night, and ever since then private message notification emails are either not being sent or are showing up extremely delayed, anywhere from 4 to 13 hours.

    Any ideas?

  • #2
    If you have "Use Mailqueue System" and "Use Cron Based Sending" set to Yes in your Email Options, then mail is sent via scheduled task which doesn't run unless your forum has traffic.

    Comment


    • #3
      I'll have to check those settings when I get home, but my site always has traffic, anywhere from 200 to 1,000 at a time.

      Comment


      • #4
        OK, then if you do have "Use Cron Based Sending" set to Yes you might need to increase the "Number of Emails to Send Per Batch". (Maybe you have more emails to send per hour than is being allowed).

        Comment


        • #5
          That might be the problem, its set to 10, that seems really low, is it? What's a realistic number to change it to

          Comment


          • #6
            I'm not sure. I know the help for that value warns against setting it too high, but the scheduled task only runs once every 10 minutes so it seems that the batch size would have to be at least 1/6 the number of emails you expect to send per hour.

            ETA: OK, I guess that batch value existed before the "Use Cron Based Sending" was added. If cron based sending is set to no, then the email gets sent in small batches every time someone makes a page request, so it makes sense to set it to something small. But with the cron based sending it needs to be much larger.

            I don't actually see the point of the cron based sending to be honest. It seems like it causes more emails to be sent by the "unlucky" few who happen to trigger the scheduled task, when without it the sending is spread over a larger number of users. Maybe I'm missing something.

            Edit: I answered my own question by reading the original mod page: http://www.vbulletin.org/forum/showthread.php?t=231715 . I guess the point is sometimes you might have a mass emailing of newsletter or something like that, and you want to control it so it doesn't kill your server or send out more emails than you host allows. So maybe the answer is that you shouldn't be using cron based sending unless you have one of those issues.
            Last edited by kh99; Sun 3rd Jun '12, 6:08am.

            Comment


            • #7
              Originally posted by klh View Post
              I'm not sure. I know the help for that value warns against setting it too high, but the scheduled task only runs once every 10 minutes so it seems that the batch size would have to be at least 1/6 the number of emails you expect to send per hour.

              ETA: OK, I guess that batch value existed before the "Use Cron Based Sending" was added. If cron based sending is set to no, then the email gets sent in small batches every time someone makes a page request, so it makes sense to set it to something small. But with the cron based sending it needs to be much larger.

              I don't actually see the point of the cron based sending to be honest. It seems like it causes more emails to be sent by the "unlucky" few who happen to trigger the scheduled task, when without it the sending is spread over a larger number of users. Maybe I'm missing something.

              Edit: I answered my own question by reading the original mod page: http://www.vbulletin.org/forum/showthread.php?t=231715 . I guess the point is sometimes you might have a mass emailing of newsletter or something like that, and you want to control it so it doesn't kill your server or send out more emails than you host allows. So maybe the answer is that you shouldn't be using cron based sending unless you have one of those issues.
              Cool, I'll try turning it off and see what happens, I'll update this thread when I crash my site

              - - - Updated - - -

              That was it, I turned off cron based sending and I immediately received 11 email notifications.

              Comment


              • #8
                Where do I see the cron based sending to turn it off?

                Comment


                • #9
                  Settings -> Options -> Email Options -> Use Cron Based Sending -> Set to "No"



                  Dustin
                  http://quikmsg.net/strtoupper/ - Convert lowercase text and code to all uppercase!
                  http://quikmsg.net/strtolower/ - Convert uppercase text and code to all lowercase!

                  Comment


                  • #10
                    This worked for me too!

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X