Announcement

Collapse
No announcement yet.

The email queue will never empty

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] The email queue will never empty

    Hi all, after 4.2.0. in my forum, the emails are not sended anymore.... the email queue is full and it'll never cleaned. There's some option to configure correctly this tool , or there's a way to solve my problem?
    Last edited by Sworm1; Thu 31st May '12, 12:08am.

  • #2
    What have you got the Mail Queue settings at:

    AdminCP > Settings > Options > Email Options > Use Cron Based Sending
    AdminCP > Settings > Options > Email Options > Number of Emails to Send Per Batch
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      But i think that there's some problem in my board.... the Number of emails to send per batch is 80, i have from this morning 21 emails in the queue. Why these emails are not sended? It wait that in the queue will be 80 emails?
      Last edited by Sworm1; Thu 31st May '12, 5:12am.

      Comment


      • #4
        Is the Scheduled Task running?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Where Lynne is going with this is, not all emails sent by the forum are sent "instantly" despite their label/identification. In fact many are sent to que and then await a scheduled task to run thereby sending them only at the time the task runs.


          Former vBulletin Support Staff
          Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
          Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
          Need a Host? - I recommend URLJet

          Comment


          • #6
            The task has runned 4 minutes ago , but the email queue is still in there, without send any notification via email.... :S

            - - - Updated - - -

            I have active ForumRunner.... can be this the cause of my problem? But it is really strange.... I have opeed a ticket with acp details

            Comment


            • #7
              It sent no email when it last ran? Is there anything in your error_logs (if you don't know where they are, ask your host)?

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment


              • #8
                What is Use Mailqueue System set to ?
                Baby, I was born this way

                Comment


                • #9
                  I just founf my last processed mail queue was processed at 25th May, after that date there is no other logged entry, just no idea if the queued have been growing since the same date, today I turned off to clean those...

                  Comment


                  • #10
                    Originally posted by Gumble View Post
                    I just founf my last processed mail queue was processed at 25th May, after that date there is no other logged entry, just no idea if the queued have been growing since the same date, today I turned off to clean those...
                    Are any scheduled tasks running? Make sure the cron image hasn't been removed from the footer template.

                    Comment


                    • #11
                      Yes few tasks are running, the cron image is present still.

                      - - - Updated - - -

                      Should the task be listed as "E-mail Queue" or similar name in the "Scheduled Task Manager"?

                      - - - Updated - - -

                      Ok after digging a few I found this logs only refer to old Paul's mod, after the upgrade I removed the disabled mod's, wonder if this can be related and a schedule task got also deleted in the process.

                      - - - Updated - - -

                      Worked now

                      The schedule was not present on both forums after running again the update without sucess, I was checking the cron tables and ended adding

                      INSERT INTO `_cron` VALUES ('20','1320000000','-1','-1','-1','a:6:{i:0;i:0;i:1;i:10;i:2;i:20;i:3;i:30;i:4;i:40;i:5;i:50;}','./includes/cron/mailqueue.php','1','1','cronmail','1','vbulletin');
                      Immediately started resolving the queue.

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X