Announcement

Collapse
No announcement yet.

CMS in root, FORUM in /forum directory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] CMS in root, FORUM in /forum directory

    OK...so here is what I want...

    www.mydomain.com = CMS (this is the page most everyone goes straight to)

    www.mydomain.com/forum = forum. (just the forum area)

    What I've done so far...

    Installed vb4.2 in /forum, and enabled the CMS. I was using vbadvanced, which was installed at the root. I'm getting rid of vba and want to use vbcms...at the root.

    I've moved the "index.php" file from the /forum/ directory and into the root directory. I've deleted the //, and that line reads as follows: define('VB_RELATIVE_PATH', 'forum');

    However, when I go to the root (www.mydomain.com), I don't see the CMS. Instead, I'm taken to http://www.mydomain.com/forum/activity.php

    So at this point, I'm stuck...I'm not sure what to do, I've searched the forums here, this has to be a popular issue, but I can't find anything that helps.

    - - - Updated - - -

    OK, I think I solved this one on my own (thank God since I didn't want to wait for days to get help)...

    To those who may have trouble in the future:

    1) upload the files in the CMS folder found in the "do not upload" folder, into the root
    2) edit the vb_dir.php file (comment out the 1st time, uncomment the 2nd line and put in the path to the forums).

    I also used mod rewrite, so I uploaded the .htaccess file from the (rewrite/cms) folder (again, found in the "do not upload" folder) to the root (and of course, the forum .htaccess from the forum folder, to the forum directory). So far, everything looks good.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X