Announcement

Collapse
No announcement yet.

Forum permission associate with User group?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lifanovsky
    replied
    Unfortunately, it didn't help as of now.. I'll try a few times more, though..

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by lifanovsky View Post
    Matthew, is there something you could advice me? I had a problem that all tagging options were set to allow, but noone could add tags - for some reason it said that "the number of tags you tried to add exceeded the maximum number of tags by 1". Though it is allowed to set 100 tags. When I ran your query it appeared that registered users CAN add tags, but supermod and admins still can't. Maybe there is something you can think of that will rebuild some other indexes that will totally solve my problem? :-) Thanks in advance!
    Edit one of your usergroups and save them to rebuild the usergroup cache.

    Leave a comment:


  • lifanovsky
    replied
    Originally posted by Matthew Gordon View Post
    Thought so. It's a problem with the second index on the table. Let me grab a query that should fix it.

    e: Run this query:
    Code:
    ALTER TABLE `forumpermission` DROP INDEX `ugid_fid` ,
    ADD UNIQUE `ugid_fid` ( `usergroupid` , `forumid` )
    Matthew, is there something you could advice me? I had a problem that all tagging options were set to allow, but noone could add tags - for some reason it said that "the number of tags you tried to add exceeded the maximum number of tags by 1". Though it is allowed to set 100 tags. When I ran your query it appeared that registered users CAN add tags, but supermod and admins still can't. Maybe there is something you can think of that will rebuild some other indexes that will totally solve my problem? :-) Thanks in advance!

    Leave a comment:


  • bbtintin
    replied
    RESOLVED, this thread can be closed. This is fixed by comment#16, thank Matthew, you save my life

    Leave a comment:


  • bbtintin
    replied
    Originally posted by Matthew Gordon View Post
    Thought so. It's a problem with the second index on the table. Let me grab a query that should fix it.

    e: Run this query:
    Code:
    ALTER TABLE `forumpermission` DROP INDEX `ugid_fid` ,
    ADD UNIQUE `ugid_fid` ( `usergroupid` , `forumid` )
    Oh my goodness.. thanks so much, it work with the very first task: Hide the forum for 'Register Users'

    Let me continue and hope it work for other too..

    Leave a comment:


  • Matthew Gordon
    replied
    Thought so. It's a problem with the second index on the table. Let me grab a query that should fix it.

    e: Run this query:
    Code:
    ALTER TABLE `forumpermission` DROP INDEX `ugid_fid` ,
    ADD UNIQUE `ugid_fid` ( `usergroupid` , `forumid` )

    Leave a comment:


  • bbtintin
    replied
    And this is mine Matthew, FYI:
    Click image for larger version

Name:	r8LkbapJt.png
Views:	1
Size:	51.2 KB
ID:	3687233

    Leave a comment:


  • bbtintin
    replied
    Yup, thanks for all advice.. actually I have failed the stack holder, i plan for a week to migrate from 5 years data of phpbb to vbb. This critical tasks pending till the end . We have to turn on the old one (phpbb) and continue live with it until I can fix this issue. I was wrong to think that the migration is 'simple', we close already the vbb until next month or until I can fix this forum permission.

    And yes Wayne, I will install a brand new vbb and see try out again the forum permission if successful with the scenario on top, then migrate data again...

    Hopefully I will pass this time.

    I subscribed this topic instantly, and listen to every moment of this thread, so any idea would be appreciated.

    I will keep you guys posted

    Thanks in advance.
    Last edited by bbtintin; Thu 10th May '12, 6:58pm.

    Leave a comment:


  • Wayne Luke
    replied
    I suggest closing the forum... Then:

    Write down your permission scheme.
    Run this query: truncate forumpermission;
    Editing a single usergroup and saving it to reset the datastore;
    Re-doing your forum Permissions.

    Somewhere along the way, something seems to have gotten corrupted so starting over with the permissions seems to be the quickest and easiest way to handle it.

    Leave a comment:


  • Matthew Gordon
    replied
    Mind grabbing a screenshot of the table structure of the forumpermission table? More specifically, the indexes. Here's what mine looks like:

    Click image for larger version

Name:	forumpermission_table_structure.png
Views:	1
Size:	53.2 KB
ID:	3687231

    Leave a comment:


  • TheLastSuperman
    replied
    I'm stumped at the moment on this... I'll keep this in mind and if anything comes up I'll pop back in this thread promptly.

    Leave a comment:


  • bbtintin
    replied
    Originally posted by TheLastSuperman View Post
    While in phpMyAdmin try:

    Click the usergroup table, it will load the page listing your usergroups and note how many are listed the default is 8.
    Now click on the operations tab.
    Look for: AUTO_INCREMENT and note the # there.

    Is the auto-increment value 1 above the number of usergroups you have listed? (For example if you only have 8 usergroups the auto-increment value should be set to 9) If no then update that in phpmyadmin and now try to save the forum permissions. Let me know what you find .
    Thanks for reply, i have checked the auto-increment. It sound logical.

    - Number of row in usergroup table is: 20 (order by usergroupid, then the last one is 38)
    http://screenshotuploader.com/s/01/rjNjDLItJ (some are added when I migrate from phpbb, some are added by manual in vbb)

    - auto_increment at Operation tab is 39
    http://screenshotuploader.com/s/01/xHElZcRqp

    Leave a comment:


  • TheLastSuperman
    replied
    While in phpMyAdmin try:

    Click the usergroup table, it will load the page listing your usergroups and note how many are listed the default is 8.
    Now click on the operations tab.
    Look for: AUTO_INCREMENT and note the # there.

    Is the auto-increment value 1 above the number of usergroups you have listed? (For example if you only have 8 usergroups the auto-increment value should be set to 9) If no then update that in phpmyadmin and now try to save the forum permissions. Let me know what you find .

    Leave a comment:


  • bbtintin
    replied
    Originally posted by Matthew Gordon View Post
    Run this query and try it again.

    Code:
    DELETE FROM forumpermission WHERE usergroupid = 31 AND forumid = 25;
    I tried with brand new group and brand new forum, the same error still happen ?!

    OK, now let me break into smaller piece so that you guys may recognize what wrong and advise could be more helpful.

    Please be patient..

    This is the first small piece:

    1/ Create a new forum container 'FF'(act as NOT forum)
    2/ Create 2 new forum FA and FB located under FF
    3/ Get in Forum Permission and edit usergroup "Register Users"
    4/ Tick 'No' on the option item 'Can View Forum'
    5/ a msgbox display as:
    http://screenshotuploader.com/s/01/IJWUCbZR2
    >> click 'Yes' Continue
    6/ Click 'Save'
    >> Error display as below:

    Invalid SQL:


    ### INSERT QUERY GENERATED BY fetch_query_sql() ###
    INSERT INTO forumpermission
    (`usergroupid`, `forumpermissions`, `forumid`)
    VALUES
    ('2', '10096886', '70');


    MySQL Error : Duplicate entry '2' for key 2
    The very simple purpose of those steps above is that, I just don't want 'Register Users' will not see this "FF" forum

    Any idea on this ?! what was wrong ?

    Leave a comment:


  • Matthew Gordon
    replied
    Run this query and try it again.

    Code:
    DELETE FROM forumpermission WHERE usergroupid = 31 AND forumid = 25;

    Leave a comment:

Related Topics

Collapse

Working...
X