Announcement

Collapse
No announcement yet.

Big problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Big problem

    Hello there joyful people
    How do you remove /forum from the url so that your url point just to the cms without a /forum in the middle of it.

    Now it looks something like
    https://www.vbulletin.com/forum/content.php


    What I want is
    https://www.vbulletin.com/content.php (or index.php doesnt matter)

  • #2
    Do you want to keep the forums in /forum and just move the CMS to the root directory?

    If so, copy the contents of the do_not_upload/cms directory to the place where you want to put the CMS. Edit the vb_dir.php file in that directory, and change this:
    PHP Code:
    $vb_dir realpath(dirname(__FILE__) . '/..');
    //$vb_dir = "/path/to/vbulletin/"; 
    Assuming you are placing the CMS in yoursite.com/ and your forums are located in yoursite.com/forum, change it to this:
    PHP Code:
    //$vb_dir = realpath(dirname(__FILE__) . '/..');
    //$vb_dir = "/path/to/vbulletin/";
    $vb_dir realpath(dirname(__FILE__) . '/forum'); 
    Afterward, go to the Admin CP -> Settings -> Options -> Site Name / URL / Contact Details and change the "CMS Component URL" to the URL to your CMS directory, e.g. http://yoursite.com
    Last edited by Matthew Gordon; Sun 29th Apr '12, 9:41pm.

    Comment


    • #3
      Exactly, I want forums in mysite/forum blogs in mysite/blogs and cms in the root
      so it should read like

      mysite.com (cms)
      mysite.com/forum (forum)
      mysite.com/blog (blog)

      Comment


      • #4
        Well, those instructions should work for moving the CMS. The blog is pretty similar, just make a blog directory and upload the contents of do_not_upload/blog to it, edit its vb_dir.php file and change the same lines above to this:
        PHP Code:
        //$vb_dir = realpath(dirname(__FILE__) . '/..');
        //$vb_dir = "/path/to/vbulletin/";
        $vb_dir realpath(dirname(__FILE__) . '/../forum'); 
        And then finally change your "Blog Component URL" (same place - Admin CP -> Settings -> Options -> Site Name / URL / Contact Details) to the URL to your blog, e.g. http://yoursite.com/blog

        Comment


        • #5
          no luck!

          Comment


          • #6
            What do you mean no luck?

            Comment


            • #7
              do you mean that I have to copy the content of the cms folder to the ​root??

              Comment


              • #8
                Yes. Copy the contents of the do_not_upload/cms folder in the vBulletin package to the place you want the CMS to be (in this case, you want it in the root of your site, so copy the files there).

                Comment


                • #9
                  Warning: require_once(/home/me/content.php) [function.require-once]: failed to open stream: No such file or directory in /home/me/public_html/index.php on line 4

                  Fatal error: require_once() [function.require]: Failed opening required '/home/me/content.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/me/public_html/index.php on line 4
                  Last edited by Matthew Gordon; Sat 5th May '12, 6:27pm. Reason: Removed links.

                  Comment


                  • #10
                    You have to edit the vb_dir.php file as I explained in in my first post.

                    Comment


                    • #11
                      I am really missing something very small..
                      Sorry to bother you thogh....

                      I have edited now the site is messed up without no styling ....
                      I am gonna pm you the site address now.. have a look

                      Comment


                      • #12
                        Make sure the "Always use Forum URL as Base Path" setting is set to "Yes". (This is located at the same place as the component URL settings mentioned earlier, Admin CP -> Settings -> Options -> Site Name / URL / Contact Details)

                        Comment


                        • #13
                          what am I missing ? still no luck|

                          Comment


                          • #14
                            Your "Forum URL" needs to be set to the forum directory, e.g. http://yoursite.com/forum

                            Comment


                            • #15
                              hip hip hoorayyyyyyyyyyyyyyyyy
                              hip hip hoorayyyyyyyyyyyyyyyyyyyyyyyyyyyy

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X