I was finally able to upgrade our vBulletin to 5.1.9 from 4.X. Everything works fine except for the Ad Module.

I'm getting following error when trying to save an Ad.

...