No announcement yet.

Always showing mobile style....

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Always showing mobile style....

    We just upgraded to 4.1.12 and have a serious problem. No matter what, the website is ALWAYS showing the mobile style, even if we click the full style from the admincp. If we click View Full Site in the footer, same thing. It just shows the mobile style.

    We've tried re-importing the default master style multiple times, to no avail.

    I'm not sure what's going on or how to fix it. Right now we have one style - Called "Default Style" with a styleid of 1. And we click it from the admincp, we're shown the mobile style. When I view the header template for this "Default Style", it is very clearly the header template for the mobile style and not the default style.

    I've tried renaming "Default Style" to "Mobile" and re-importing the default style, and that didn't work either. No new style ever shows up in the admincp.

    At this point, I don't know what else to do. This is driving me crazy.

    Please help

  • #2
    Change your default style under Settings -> Options -> Style & Language Settings. Set it to one of the "Standard" styles.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.


    • #3
      We USE the standard style already. That's what I'm saying. The default is already on "Default Style" and "Default Style" CONTAINS the mobile style.

      Look. Here is the code for the header template of our default style:

      <div data-role="page" data-theme="d" id="page-home">
      <div id="header">
      	<div id="header-left">
      		<a href="{vb:link forumhome}" class="logo-image" rel="external"><img src="{vb:stylevar titleimage}" alt="{vb:rawphrase x_powered_by_vbulletin, {vb:raw vboptions.bbtitle}}" /></a>
      	<div id="header-right">
      		<vb:if condition="$show['member']">
      			<vb:if condition="$notifications_total">
      				<a href="mobile.php?{vb:raw session.sessionurl}do=notifications" data-role="button" data-inline="true" data-theme="e" class="notifications_total hidden"><span class="notifications_total_count"></span></a>
      		<vb:else />
      			<a href="mobile.php?{vb:raw session.sessionurl}do=login" class="headericon" rel="external"><img src="{vb:stylevar imgdir_mobile}/login.png" /></a>
      		<a href="mobile.php?{vb:raw session.sessionurl}do=gridmenu" class="headericon"><img src="{vb:stylevar imgdir_mobile}/gridmenu.png" /></a>
      		<a href="search.php?{vb:raw session.sessionurl}search_type=1&amp;contenttype=vBForum_Post" class="headericon" rel="external"><img src="{vb:stylevar imgdir_mobile}/search.png" /></a>
      	<vb:if condition="$notifications_total">
      	<ul id="dummylist" class="hidden">
      		{vb:raw notifications_menubits}
      As you can see - Our default style contains the mobile style code. And no matter how many times I re-import the default style, it never does update the templates with the default style code.

      We have always used the default style. No extra mods. Just a vanilla forum. So there is no reason this upgrade should have screwed up like this.

      In the style options, we have two choices:

      A blank line
      "Default Style" (Which is classified under "Mobile Styles" for some reason)


      • #4
        This MySQL query should move your default style back to a standard style. Run it in phpMyAdmin or Admin CP -> Maintenance -> Execute SQL Query. Things to note: if you have a table prefix, you need to add that in front of "style" at the beginning of the query, and if your style's styleid isn't 1 (if it is the default style, it should be) then you need to change that at the end of the query to the proper styleid.
        UPDATE style SET parentid = '-1', type = 'standard' WHERE styleid = 1;
        After the query successfully runs, go to in your browser to rebuild the styles. Also, since it seems that there isn't a default mobile style, I'd suggest making a new style called "Default Mobile Style" (Admin CP -> Styles & Templates -> Style Manager -> [Add New Style] at the bottom) making sure to select "No Parent Style" under "Mobile Styles" (it defaults to "No Parent Style" under "Standard Styles", this is not what you want).

        After all that, go to Admin CP -> Settings -> Options -> Style & Language Settings, make sure "Default Style" is your default style and that "Default Style for Old Mobile Browsers" and "Default Style for Modern Mobile Browsers" both show the default mobile style. Save those settings.


        • #5
          Thank you!


          • #6
            I have the same problem
            After Upgrading from 4.1x to 4.2

            I am always looking at the mobile template
            vb4 Default Style is inside Mobil Styles

            I added another template from another site, and it let me change to that new template

            But I can't choose the vb4 Default style
            I already run the sql query above, and nothing happens, still with same problem

            How can I solve this?



            • #7
              If you run the query above, make sure you add a table prefix if you are using one.

              If you upload a style to the Standard Style area, it should be pickable when picking the default style under AdminCP > Settings > Options > Style & Language Options > Default Style.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools &lt;- awesome site for html/css help


              • #8
                I have not any prefix

                I navigated in the table structure
                And changed manually the option of Mobil to Standar, and that fix it



                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.