Announcement

Collapse
No announcement yet.

Internet Explorer issue - grey box replying to threads

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Internet Explorer issue - grey box replying to threads

    OK, I am having the same problem as some who have reported compatibility issues with Internet Explorer.

    We just upgraded to vBulletin 4.1.12 this week.

    Click on: + Reply to Thread
    Then
    Click on: Go Advanced

    The box is greyed and users can't type in it. The problem is only with Explorer. FireFox and Chrome work in Quick Reply and Go Advanced, no problem. The only way to workaround this problem is hold down left mouse button and drag (resize) the bottom right of the greyed out box, release mouse, then the box is active and you can type in it. That action seems to activate the window.

    Click image for larger version

Name:	greyed-reply-box.jpg
Views:	1
Size:	60.0 KB
ID:	3723202

    I have followed the advice of others experiencing these problems. In Admin Control Panel, I turned off the Quick Reply option for a couple of hours, then turned it back on. I've turned other options off then back on in Message Posting Interface Options and Message Posting and Editing Options.

    I have checked settings in Style & Language Settings, cleared cache, logged in with my test user account, removed plugins, disabled hooks, ensured I'm using standard vB template, etc.

    Problem remains: Internet Explorer users are unable to post on our forum using Go Advanced function to reply to threads. This appears to be a common problem for IE users. Is there a patch for this? There are some serious issues with the latest vBulletin and IE compatibility.

  • #2
    I didn't quote from your post just clicked on Reply to Thread then Go Advanced.
    No problems here on this forum or in my forum,using IE9.


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Another user contacted me minutes after you posted. I have had seven complaints today about this issue. They all report the same problems

      The latest user says he is using IE 9 and Windows 7. He reports the same problem I described above. He can Reply to Thread, but the editor is greyed out after clicking on Go Advanced.

      My colleague in the office next me who is also using Explorer 9 and Windows 7 reports the same problem, too.

      I am also using Windows 7. So, three of us using Explorer 9 and Windows 7 have the same problem on different computers. We've each cleared our respective caches.

      We can force the editor to activate by resizing the editor box or the browser window. It seems that the editor doesn't auto activate in Go Advanced.

      I resolved this same issue in the Quick Reply editor by changing the settings in admin control panel. I selected Yes, Click Required and suddenly the Quick Reply editor activated after the user clicks on the Reply to Thread button.

      However, before I chose this Yes option, the Quick Reply editor was greyed out and inactive until resizing the editor window or browser window. The editor seems to need some kind of action to wake it up into activation.

      Click image for larger version

Name:	greyed-out2.jpg
Views:	1
Size:	94.2 KB
ID:	3687071

      BTW, I tried to respond to this thread using Explorer 9 and the Go Advanced function. The editor box was greyed out and inactive until I resized the box. So, there's something funky going on, as our administrator, a moderator and some users have been making the same observations from different parts of the world over the past three days since we upgraded. No probs with editors of the earlier vBulletin version we had been using for several years.
      Last edited by atomiczombie; Wed 18 Apr '12, 10:08pm. Reason: added additional info.

      Comment


      • #4
        What happens when you disable your addons and are using the Default Style?
        BTW, I tried to respond to this thread using Explorer 9 and the Go Advanced function. The editor box was greyed out and inactive until I resized the box.
        I do not have that problem using IE9 with Windows 7.


        vB5 is unequivocally the best forum software, but not yet...

        Comment


        • #5
          Disabled addons, plugins, etc. Verified in admin control panel - using Default Style.

          Greyed box after clicking on Go Advanced button remains.

          Could it have something to do with the new vBulletin Auto-Save option?
          WYSIWYG editor?

          We're grasping at straws to understand why this is happening with this latest vBulletin version.

          Here's print screen of what we and our IE users are seeing:

          Click image for larger version

Name:	greyed-reply-box3.jpg
Views:	2
Size:	47.3 KB
ID:	3687072
          Last edited by atomiczombie; Wed 18 Apr '12, 10:41pm. Reason: added print screen

          Comment


          • #6
            So, I re-sized my IE browser slightly and that seemed to wake up the WYSIWYG editor in the Go Advanced option.

            Also, the editor wakes up if you slightly re-size the box by dragging on the bottom right of the Reply to Thread window.

            Voila - the Advanced editor is now activated. Still, a user shouldn't need to do this. I realize it's almost 3 am. I'm hoping someone out there can propose a solution. I've tried what others on this forum have already suggested in other threads. I'm at a loss to explain this IE issue.

            Click image for larger version

Name:	ok-reply-box.jpg
Views:	1
Size:	38.0 KB
ID:	3687073

            Comment


            • #7
              Chrome and FireFox are behaving OK. It's just Internet Explorer and its usual weirdness. Not playing nice with JavaScript?

              http://msdn.microsoft.com/en-us/libr...=vs.85%29.aspx

              "Most of these frameworks have already been updated to work correctly in IE9. However, many sites are still using older versions of JavaScript frameworks that are not compatible with IE9." Hmmm...


              Click image for larger version

Name:	editor-probs.jpg
Views:	1
Size:	50.7 KB
ID:	3687074

              I found this on a software company's web site: "...does not support Internet Explorer 9 because Microsoft has changed their javascript engine and the built-in wysiwyg editor is not compatible with Internet Explorer 9."
              Last edited by atomiczombie; Wed 18 Apr '12, 11:22pm. Reason: additional info

              Comment


              • #8
                This just gets better and better!

                From Microsoft re: How to use Compatibility View in Internet Explorer 9
                http://windows.microsoft.com/en-US/w...net-Explorer-9

                "Websites that were designed for earlier versions of Windows Internet Explorer might not display correctly in Internet Explorer 9. However, you can often improve how a website will look by using a feature called Compatibility View."

                So, does this mean that all software developers need to figure out their own workarounds just to play nice with IE?

                Comment


                • #9
                  I tried this as a suggestion on another thread here: Settings > Options > Cookies & Header Options > Force Latest IE Mode (at the very bottom). This needs to be set to "Yes".
                  Yep. Did that. No improvement in Quick Reply and Go Advanced editors using IE 9.

                  Still using my forum test account and IE 9 to view my forum and re-create the problems my IE users have been reporting.

                  So, I went back in to: Message Posting and Editing Options again. For Quick Reply, I chose Yes, Click Required:

                  This option forces users to click on Reply to Thread beneath each thread (never had to turn this option on in previous vBulletin versions - Quick Reply was always visible below each thread):

                  Click image for larger version

Name:	greyed-reply-box7.jpg
Views:	1
Size:	69.2 KB
ID:	3687078

                  The Quick Reply box is active and enabled:

                  Click image for larger version

Name:	greyed-reply-box8.jpg
Views:	1
Size:	79.8 KB
ID:	3687079

                  However, the problem remains when you click on Go Advanced. The box is greyed and inactive.

                  Click image for larger version

Name:	greyed-reply-box3.jpg
Views:	2
Size:	47.3 KB
ID:	3687083


                  Back to: Message Posting and Editing Options again.

                  For Quick Reply, I chose Yes, Click Not Required.

                  However, the Quick Reply is greyed and inactive, as well as in the Go Advanced WYSIWYG editor.


                  Click image for larger version

Name:	greyed-reply-box5.jpg
Views:	1
Size:	74.9 KB
ID:	3687076

                  My current settings in Message Posting Interface Options:

                  Click image for larger version

Name:	wysiwyg.jpg
Views:	1
Size:	53.2 KB
ID:	3687084


                  I'm at a loss, folks. Before we upgraded to 4.1.12 earlier this week , we never had an issue with Quick Edit and Go Advanced WYSIWYG editors, so something has drastically changed. Your help is needed and appreciated.
                  Attached Files

                  Comment


                  • #10
                    ** Bump ** Anyone? This is a serious problem for our users. There are other threads here discussing this problem.

                    Were the issues resolved? If so, how? Thanks.

                    Comment


                    • #11
                      I've only see this on one other site and it was a js conflict (possibly with other stuff running).

                      Can you do the following:
                      Disable third party addons.
                      Switch to the default english language with no translations or custom phrases
                      Switch to a default vBulletin style with no modifications or changes at all.
                      Are you using cloudflare or any other CDNs sysytems that might be doing things to your css files a second/third time?

                      Comment


                      • #12
                        There is an issue with IE8 and IE9 whereby if you have more than about 30 stylesheets called it stops loading any more, which can manifest itself in this way. I had it, and it took weeks and weeks to sort because it only happened occasionally, and only to the odd user in odd threads. I could replicate it though by logging in as them. It was weird.

                        Anyhow if you're in a completely default style with no plugins or add ons or code changes running it's probably NOT the above, but I thought I'd mention it.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.6.4 Demo
                        AdminAmmo - My Cloud Demo

                        Comment


                        • #13
                          Yes, Mark, that's happening to us, too. We thought at first it was caching. It's only some IE users, some of the time.

                          We're using VB4 default style and checking the few plug ins we are running to see if there are errors in their code. The Facebook widget had a closing tag issue earlier last year that we fixed, but after that worked fine in the previous VB4 version we had been running for several years. No issues with IE, Chrome or FireFox issues. Weird that suddenly there are problems.

                          We do have: Google Adsense, Google Analytics, Amazon, Everywhere Sidebar, and the vBulletin Content Management System.

                          Disabled third party addons.
                          Default English language. - Yes
                          No Cloudflare Content Delivery Systems.

                          We have a pretty basic forum. Not making much headway in the growing list of glitches and display problems since we upgraded last week. Very frustrating.

                          Comment


                          • #14
                            Still no luck solving this problem. We are running an almost "out of the box" install of 4.1.12, and all was well before the upgrade.

                            When I scour the net for ideas, I come across a lot of other forums where users are reporting this same issue, but never a solution...

                            http://www.forumlaunchers.com/Thread...ing-to-threads
                            http://www.howardforums.com/showthre...t-edit-my-post
                            https://www.vbulletin.com/forum/show...on-not-working
                            http://boardreader.com/thread/GO_Adv...r213X7z8v.html
                            http://www.vbulletin.org/forum/showthread.php?t=193058


                            Seems we are not an anomoly and this issues quite widespread. (found 20+ links with the same problems reported). Searing Google for "vbulletin "go advanced" not working" brings up many more.

                            At this point I am considering a hack that modifies the editor code to basically resize the box on reload as this seems to bring the input box back to life in IE. This is an ugly hack indeed, but options are running out!

                            Comment


                            • #15
                              Start a support ticet.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X