Announcement

Collapse
No announcement yet.

Error #2038 when uploading attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Error #2038 when uploading attachments

    Hello, we recently changed servers. Since then when trying to upload I get this error:

    500 [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2038"]

    I have tried changing a multitude of settings to no avail.

    URL: http://www.nzxt.com/forums
    PHPInfo: http://www.nzxt.com/forums/index.php?do=phpinfo
    Any help would be greatly appreciated, thanks!

  • #2
    I believe this will be a host related issue. Specifically mod_security/mod_security2 You will need to work with them to find the trigger and set the configuration accordingly or disable them.

    Comment


    • #3
      I've tried with
      SecFilterEngine Off
      SecFilterScanPOST Off
      In my htaccess, but got an error trying to load the page after, so I tried

      <IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off
      </IfModule>
      This allowed me to load the page, but uploads still are not functional.

      Comment


      • #4
        mod_security/mod_security2 may or maynot show in your php config output as it has been known to fly under the radar so to speak. You will need to review your log file and look for the error, then config mod_security/mod_security2 accordingly or disable it. htaccess is not configuring it but rather trying to get around it.

        Comment


        • #5
          Please run the Upload File Diagnostic and post the results here. Maintenance -> Diagnostics.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            Originally posted by Wayne Luke View Post
            Please run the Upload File Diagnostic and post the results here. Maintenance -> Diagnostics.
            Uploaded with no errors.

            Comment


            • #7
              Do you know what version of Apache and ModSecurity you have running? Also double check the directory permissions if your using file storage.
              Last edited by 1QuickSI; Tue 17th Apr '12, 12:00pm.

              Comment


              • #8
                Originally posted by 1QuickSI View Post
                Do you know what version of Apache and ModSecurity you have running?
                Apache/2.2.21 (Unix)

                Comment


                • #9
                  The error in question is a permissions error with the Flash Uploader. Go to Settings -> Options -> Message Attachment Options. Set "Asset Manager - Enable" to Yes, Ajax upload by default. Does it work now?
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    Originally posted by Wayne Luke View Post
                    The error in question is a permissions error with the Flash Uploader. Go to Settings -> Options -> Message Attachment Options. Set "Asset Manager - Enable" to Yes, Ajax upload by default. Does it work now?
                    Attempted to upload a file, after it was done uploading it showed no change, the file did not show up on the server.

                    Comment


                    • #11
                      I just changed asset manager to no and tried uploading and got a more detailed error stating it could not write to /attachments/1

                      I CHMOD it to 777 from 755, I am going to CHMOD the other existing folders, I tested with a newly made account the new directory was 777.

                      Thanks for the help guys

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X