Announcement

Collapse
No announcement yet.

4.1.12 - Strict Standards Errors Preventing Install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] 4.1.12 - Strict Standards Errors Preventing Install

    Thought I would post about this as it's wasted a couple of hours of my life today when I decided to put in a clean install of 4.1.12.

    My problem was that I was seeing the following when loading up install.php

    Code:
    Strict Standards:  Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in /var/www/vbulletin/includes/class_core.php on line 3341
    Strict Standards:  Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in /var/www/vbulletin/includes/class_dbalter.php on line 882
    Strict Standards:  Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in/var/www/vbulletin/includes/class_dbalter.php on line 882
    Strict Standards:  Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in/var/www/vbulletin/includes/class_dbalter.php on line 882
    Strict Standards:  Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field() in /var/www/vbulletin/includes/class_dbalter.php on line 882
    Strict Standards:  Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query() in /var/www/vbulletin/includes/class_dbalter.php on line 882
    In PHP 5.4.0 E_STRICT became part of E_ALL. From what I can work out this has resulted in E_STRICT errors being thrown when loading install.php.

    I started off by explicitly disabling E_STRICT in my php.ini, but they still seemed to be getting thrown, so to make life easy I just set 'display_errors = off '. Here's where my problems started, despite it being turned off, the errors kept being shown. I fiddled about looking for addition places where display_errors may be set, but found nothing. I created a <? phpinfo(); ?> file but that showed display_errors as being off as well. After a couple of hours of banging my head against a brick wall i modified install.php to have a phpinfo(); at the bottom, surprise surprise display_errors is now showing as on...

    I then search through the required files and found that init.php has this little gem:

    Code:
    // try to force display_errors on
    @ini_set('display_errors', true);
    Thanks guys, that really made my day.

    A quick tweak to this file to turn display_errors to off and the whole install went through flawlessly, shame I won't get those hours finding this back...
    Fyrespray

    http://www.ardescosolutions.com
    http://www.lazeryattack.com

  • #2
    Hi,
    i commented out line 25 in the init.php and nothing happens. same erroers...

    Comment


    • #3
      There is an ongoing thread about this in the licensed feedback forum where this change is listed.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        Hi,
        is this possible via .htaccess or php.ini ?
        I don't have root access

        Comment


        • #5
          Originally posted by hollosch View Post
          Hi,
          is this possible via .htaccess or php.ini ?
          I don't have root access
          http://php.net/manual/en/configuration.changes.php
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            Does anyone have a solution for this? I'm using xampp and can't get vBulletin installed. I just need a few variables for the CMS which are not provided.
            Payday Advance

            Comment


            • #7
              Should try the code edit in the first post? Alternatively use PHP 5.3.19 with XAMPP.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #8
                Thanks. It ended up working randomly after the 9th Apache restart. I have no explanation for that one, but the above solution did work. Thanks!
                Payday Advance

                Comment


                • #9
                  here is a tested working solution until vB team can fix the issue.

                  A quick solution was to do the following

                  open ./includes/config.php
                  add to top on next line after <?php
                  PHP Code:
                  // try to force display_errors off
                  @ini_set('display_errors'false); 
                  open ./includes/class_core.php
                  find
                  PHP Code:
                  $this->shutdown vB_Shutdown::instance(); 

                  replace with
                  PHP Code:
                  $this->shutdown [email protected] vB_Shutdown::instance(); 

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X