Announcement

Collapse
No announcement yet.

Two issues with editor: Extra whitespace & cursor jumping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Two issues with editor: Extra whitespace & cursor jumping

    I'm a new vBulletin user, and while I like the software a lot, there are two really annoying problems occurring when entering messages in the editor.

    Problem #1: Extra Whitespace from pasting

    Copying and pasting text into the standard editor often inserts extra line breaks. I find that it usually doubles the linebreaks, meaning one blank line will turn into two, two will turn into four, etc. Is there any way to fix this? Why is this happening?


    Problem #2: Weird Cursor Movement

    This happens with both the WYSIWYG editor and the standard one.

    Do the following:

    Type the statement "This bold text", using the "B" bold control to turn the world "bold" into boldface.

    Now try doing it, but try backspacing the word "bold" after typing it. You'll find that the cursor goes nuts, and jumps to the spot BEFORE the boldface.

    This is driving me (and my users) crazy.



    Is there a fix for either of these things?

    I have Vbulletin 4.1.1

  • #2
    Bump. Can anyone help?

    Bueller?

    Comment


    • #3
      It would be helpful if you indicated which browser you're using.

      Comment


      • #4
        Originally posted by Dan Druff View Post
        Problem #1: Extra Whitespace from pasting

        Copying and pasting text into the standard editor often inserts extra line breaks. I find that it usually doubles the linebreaks, meaning one blank line will turn into two, two will turn into four, etc. Is there any way to fix this? Why is this happening?

        Problem #2: Weird Cursor Movement

        This happens with both the WYSIWYG editor and the standard one. Do the following:

        Type the statement "This bold text", using the "B" bold control to turn the world "bold" into boldface.

        Now try doing it, but try backspacing the word "bold" after typing it. You'll find that the cursor goes nuts, and jumps to the spot BEFORE the boldface.
        I have both of these problems as well. I mainly use Chrome.

        And it's happening right now as I type:
        1. Type: This is
        2. Hit SPACEBAR
        3. Press CTRL + B
        4. Type: bold
        5. Press CTRL + B
        6. Hit SPACEBAR
        7. Type: text
        8. Hit SPACEBAR
        9. Hit BACKSPACE
        10. Cursor jumps and deletes the d


        There's a bug report on this: http://tracker.vbulletin.com/browse/VBIV-13549. The bug report says that it's related to Chrome, not vBulletin.

        I tried updating Chrome (Version 23.0.1271.64 m), but I still get the error. I'll submit the error to the Chrome developers; maybe that will help.

        Comment


        • #5
          Necro post, but found it while trying to find a solution to me having the same problem.

          I also run Chrome.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X